[Master] Mystic Vision bugs, again


Mystic vision is broken again today.
First the ad (Toon Blast) played and froze at the end (no cross to leave the add and go back to the game), I had to shut the app down.
Then another ad (Sheriff of Mah-jong) started and the app crashed.
Third time around, I get an error message, « sorry, you have used all your mystic visions, please come back later » (meh?).
Then the gem flag reappears, I click, Sheriff of Mah-Jong again, plays till the end and then freezes.
I’m not spending my morning trying to get a Mv reward…

Please fix your decaying game. We need that more than the 15 new 5* heroes a month. :roll_eyes:

Not fixed. Btw, it’s iOS.

I watch a number of Mystic Vision ads a day, which lead to no reward, nothing, just - - > back to the game.
That’s a lousy error. They’re getting paid, and I’m getting nothing, just wasted minutes of my life!
It’s maybe even an error they’re aware of but they benefit from, so they don’t fix it?

I watch the videos, wait the time. When I exit, I get no rewards. This has happened close to a dozen times now. Several a few months ago, and recently 3x

Hi all.
Is there something wrong with the Ads?
Usually when you hit the Ad once you watch it and you get the “reward” afterwards.
Today…I watched the same advertisment 3 or 4 times before get a reward…
Is this a…“bug” or something else?
Thank you anx have a nice day

The Mystic Visions this morning (4 at last count) won’t display properly on iPhone. They appear “too big” and the close button at the end, necessary for receiving the award, is off the screen and you can’t click the X to close them. Cannot move the image to bring it into screen either. Had to switch to iPad. Annoying.

MV issues strike again. The ads play fine, but the final ad screen is shifted right and the close function is inaccessible. The game must be closed and then no reward is received and MV is available to watch again with the same results. Tried for several days and always get the same results. Probably watched 10+ ads and got nothing.

Let’s trouble shoot:

  1. Android or iPhone?
  2. Have you latest phone/device OS?
  3. latest E&P update?
  4. Do you have a screenshot of the error? Can you post below?
1 Like

Every one here, as well as the developers, know Mystic Vision is well and truly broken. So, would someone please make a dump for the unheeded complaints. That shoulda make it easier to ignore.

It exists. I just searched “master mystic vision”.

When I login, why it always shows you have exhausted your mystic visions try again later?

Hey, Rook, long time.

I was doing the sincere/sarcasm thing.

Have the devs acknowledged that there is a new and worse problem with MV?

Honestly, the current MV requires a player to get out and return. I had crypto.com pop up three consecutive times (remember this is never being able to claim a reward) then a different sad (same no function log out in) then twice more crypto with the google play at bottom (unlike first) with the proper function on the 6th try.

Mystic Vision says check back later…every day for like a week now. Resetting device doesn’t fix it. Any advice?

Not to my knowledge…but they haven’t said there isnt a problem, hence the thread.

I assume you have done the usual:

  • Downloaded your device’s latest update

  • Downloaded E&P’s latest update

  • Turned your device completely off, then on

  • Reported the problem to E&P Support (screen shots are helpful)


No, my cat-loving friend, I have not.

I want feedback from users since they are sure to respond. Therefore, I went to the forum ss opposed to e&p.

Happy holidays

I use two Android devices (Galaxy 20 and Galaxy 5) and I often get the “check back later”. I tend to just wait 20-30 seconds and it automagically reappears for me and then it works.


The ad for progressive frequently freezes @ 29 seconds (before giving the option to race) and will not close. Anyone else reporting this?

I’ve been getting Check back later for hours and hours. Last one that appeared was about 8 hours or so ago.

Update… it’s been 10 hours since I posted this and still no Mystic Vision available. Bug maybe?

My experience is, just wait about 20 seconds and it comes back again.

For the past 24 - 48 hours I’ve noticed that the mystic vision isn’t appearing as available every 4 hours as it should.
The last 12+ hours, it hasn’t appeared once and it still says “No ad available. Check back later.”

I’ve restarted the game, phone, uninstalled the app, reinstalled it and nothing.

Running iOS 15.1.1 on iPhone 13 Pro. Game version 44.

If anyone has suggestions, it would be appreciated.