Did not receive gems for challenge offer


#1

Dear Support, I used your special challenge offer (300gems for 0,99€) two times. Both payments via google payment were conducteted consecutively in short time about 13:25, 13:28 CET Oct 5, but I received only 300 gems for the first payment. Please correct it and provide 300gems to my account. acount name is roland. Thx! If you need further info pls contact me via email.


I did not get gems I purchased
#2

300 for 0,99€? Thanks a lot SG … I am only offered 200 for 0,99€. Well, than again … no money from me.


#3

Yeah, same here (200 for .99). Still a good deal though.


#4

Hi, @roland, sorry to hear that you didn’t receive the gems!

In most cases, the purchases are delivered instantly but in some cases there might be a delay in processing the order. More information here: https://smallgiant.zendesk.com/hc/en-us/articles/115003892065-I-didn-t-get-my-order-

If you still haven’t received the gems after 24 hours of purchase, please contact us by submitting a ticket here: https://smallgiant.zendesk.com/hc/en-us/requests/new so we can investigate this in more detail. Remember to attach a receipt from Google or Apple!

By the way, the Challenge Offer is indeed 200 gems and this is same for all players. :slight_smile:


#5

I purchased the deal…99cents for 200 gems and did not get them


#6

Like the others, made confirmed payment purchase with no gems received and no reduction in quantity available, still showing 5 available. All previous purchases have been immediately delivered, why the problem this time? Will wait the 24 hr period but don’t want to miss the event summons so please resolve your issue ASAP. Will not purchase anything more until this is fixed.


#7

Similar here, went to payment option then my net connection was lost - despite it showing 5 available I can’t even purchase at present as it says I’ve already bought it… So not got the 200 gems and can’t buy any more if I wanted to.

Just to update - my problem resolved! 6 hours later, not sure if from this post or the system catching itself up - thanks either way :slight_smile:


#8

If this has not self resolved then I suggest you follow up with SG by using the in game support button (found in the options menu).


#9