Account reset

Hey, yesterday or two days ago a Pop-up arrived telling me to sync my account with Google Play, which I thought was weird since I´m 100% this was already the case. Anyway, I verified with the same e-mail my Google play account is active on. I played throughout the day, however, around 10 hours after the activation occurred. I got a notification that one of my buildings was done so I opened the game, and the tutorial for a new player starts meaning that my old account was either reset or something else happened.

Please give me advice on how to solve this issue.

Best regards,
Johan

Contact Customer Support is the best I can suggsst.
https://smallgiant.zendesk.com/hc/en-us/articles/360000542934-How-to-Contact-Support-v1-9-7-onwards-

1 Like

Can I reach this support button without having to play through the entire tutorial??

There’s also a link at the bottom of that page to contact Customer Support without going through the game.

1 Like

Was this solved? I am having a similar problem here. Level 36 elder in a alliance, almost 1 year playing this game and then I got reseted back to level 1!

You will need to contact support for help with this.

Just did, NO answer. More than 24 hours gone.

That sucks.

@Petri, can you help with this at all?

I am experiencing the same thing! Game started me completely over! I’m level 51 and an elder as well! I’ve been back and forth with support staff and getting nowhere! I know my original account was saved on Google play games. I even spoke to Google play games support staff and they were able to see the problem, however they’re not able to fix it. They said the problem is on the developer side! I have tried EVERYTHING except deleting data. Somehow, after the update, is when it started me over and I haven’t been able to access my original account since. I didn’t think it was possible to have 2 accounts using the same Google account but it happened! My original account still shows up on my alliance but I can’t access it because it takes me straight to the new beginner game! Please help

1 Like

Did you submit a support request yet? No one in the forums can help with this issue.

Its just RIDICULOUS and all their responses seem automated as if they’re based on keywords in the emails!

Yes I submitted 2 requests for for this issue. I submitted the first request October 13 when it happened… Been emailing back and forth with them… It wouldn’t let me reply to this last email so I had to make another request! ! They’re showing it as solved but it’s not

I gave them ALL of the info they requested along with additional info and they still sent those automated responses!

https://smallgiant.zendesk.com/auth/v2/login/registration

You can sign up, and as long as you sign up with the same email that is tied to your account, you should see your support requests. You can also comment on them in there and see status.

Once again, support has to handle these issues. No one on the forum is able to help.

I’m already signed up and that’s how I saw that they marked the issue as solved. I would think that if Google play found the problem maybe E&P would too. Very frustrating starting over from a level 51. Ty. I’m still navigating thru the forum stuff

Cookie Settings