Version 20: Can't log into game, says new version available but it isnt [MASTER]

If my memory is correct then this is a problem with google play rather than the game. I would try restarting your phone, but there are probably more technical people who could offer more detailed advice :slight_smile:

1 Like

No update available for me too… I’m using a Samsung device

I tried this and no-go. I appreciate the advice though. I guess ill just wait…empires and patience, lol :thinking: :wink:

1 Like

Aqui comigo a mesma coisa, sou do Brasil, estou com mesmo problema e ninguém se manifesta sobre o assunto.

Brasil com mesmo problema. Nenhuma resposta

Google translation by moderator:

After the last update my game is in infinite login screen and when I log in asks to update the game, but no new update exists. I already deleted the game and installed again and it did not solve

Original

Depois da última atualização meu jogo fica em tela de login infinita e quando consigo entrar pede para atualizar o jogo, mas naonão existe nova atualização. Já excluí o jogo e instalei novamente e não resolveu

The screen freezes and it tells you a new update is available when I have already updated the game.

1 Like

I saw an update available in the Play Store, but got a message telling me the game needed more storage space . . . when I deleted some apps and went back to the Store, the update was no longer available. This may be related to the connection issues above.

So the game is forcing me to update my game and there is no update available yet in the Google play store… and it will not let me into the game… so what on earth do I do? Uninstall the game and redownload it and go through that God awful tutorial? I almost would rather uninstall the game for good instead of doing that lol! But seriously, does anyone have any ideas on how to fix this?
Screenshot_20190320-231731_Empires

Screenshot_20190320-231737_Google%20Play%20Store

same problem here

so what to do ???
restart the phone didnt help

I restarted my phone too… I have no idea what to do… some of the line groups I’m in are telling me to uninstall the game, but people in here are against that…

i surely didnt uninstall it with 54 5* if i am not sure that i get it back again and i am really unsure to get the same heroes again even its connected with google play.
its not sure that there is a backup of it

That’s what makes me really nervous about uninstalling too. I got 1.5 years of stuff on my account and if it were to be lost, I think I in return would lose my mind lol

Im wondering if i’l just have to be patient and hope the Google play store shows the update before the war is over… I just think its ridiculous that the game is forcing me to update when it’s not available to me yet and I cant get into the game until I can update

Same thing here. I’ve uninstalled the game on my phone and reinstalled it and no change. The game is also installed on my tablet and it still work; no loss to my account ( yet…). It get me upset…

1 Like

I’d be careful of uninstalling but you should be able to as long as you’re logged in to Google Play. I strongly suggest you take a screenshot of your account number once you get back in.

Well if Jys has already tried uninstalling the game and that didnt work, I’m wondering if that means i just have to be patient? I just am more annoyed cause they sent out this update during war… and on top of that the game is refusing to let me play

They shouldn’t have done the update during a war and Trials. Very dumb move in my opinion but they must have had a reason. I hope so at leadt

1 Like

I sure hope there was a good reason for it too, but I doubt it when I read the update notes lol. I just think small giant might also have a small brain sometimes lol

i had open a post too , same problem , but i have pc simulater and was update

Cookie Settings