V21 Mystic Vision Requiring Multiple Viewings To Get Reward

After the latest uppdate today the global aswel as the alliance chat disappered and I watched Mystic Vision twice without geting any reward for that. Now its is ready to show me something for the 3 time just seconds after I watched the last time. What is happening?

1 Like

Have you checked under recent activity if it has not been awarded at all?

I have the same. I watch the video and get nothing, and then another video is available. Sometimes after 3 videos I finally get a reward.

I watched a 3:d time and then I got the reward but all chatta are gone and then they are back and a little later they are gone again. I supose I have to whait 8h to know whats happend to the Vision, still had to watch 3 times to get 1 reward in the end.

1 Like

Yeah I watched 4 ads earlier, having to restart app each time to be able to hit vision again before it gave rewards

1 Like

Aconteceu o mesmo comigo, assisti a visão mistica e não veio a recompensa. Assisti 4x, tendo que reiniciar o aplicativo e não recebi nada.

Same. Last night, it happened once. I was able to restart the game and watch a second ad, then it worked. Today, I’ve done that three times with no success.

I’m experiencing the same problem today. Watched 3 ads and no reward. About to watch the 4th one so we shall see

Mine was broken yesterday, then it was fixed again. Just now it played the ad, no reward and if you hit on it again it says “you’ve exhausted your mystic visions”.

I’m exhausted alright :persevere::zipper_mouth_face:

EDIT: I closed the app, got another ad and this time no rewards, and frozen when I touch on it.

Kind of making me angry that I’m watching lots of ads without any rewards!

I have a bug, yet I do get rewards. Ever since the update the advert is “world war rising” every single time. I’m so sick of towers, farms, tanks and planes!!!

I have the same problem with mystic vision since yesterday

Same problem here since today. Had to restart the app after watching one with no rewards. Worked at second attempt.

After five videos my reward is NOTHING. Sick and tired of these things.

If you are having an issue, please submit a request (ticket) so that SG is aware it is impacting you:

From in-game:

Menu > Options > Support > [Support] button, Then click the 3-horizontal lines at top right and choose “Submit a request”

2 Likes

Same here. I watch Mystic vision, and there are no rewards. It appears that I’m able to view a new MV, but when I press the play button, nothing happens. I restart the game, and then I can watch MV, but again no rewards and again the play button remains but I’m not able to use it. Bug appeared in latest update.

Very same thing happening here. I havd two tablets and at first it was only happening yo the one. Today it’s started happening on the other.

Very annoying! I fully support in-game ads but I’d like to get my rewards for watching them!

Every day same thing. How many times do you have to watch the mystic vision to get your rewards ladies and gents???

I have same problem. Yesterday i watched 4 times and then its stopped open. Today not even open Mystic Vision to me. Problems started after last update

Do not forget that this “bug” is very good for their pockets. They won’t do anything very fast.

1 Like

Hey Guys! Please make sure you are playing on the newest version of the build, Version 1078 for Android. If the issue still persists, please submit a Support ticket.

3 Likes

Cookie Settings