Updated game but still unable to continue Event battle -- Not Solved


#1

I updated the game on iOS to the version specified in the in-game message. On level 10 of the
Epic Challenge event. Tried to use 75 gems to continue and same thing happened. Heroes all revived but the pop-up box to use 75 more came up. Unable to continue. Wasted another 75 gems plus all the battle items to get me to that point and the energy. Very frustrated. Don’t tell us it is fixed if it is still broken.


#2

Yeep. I lost yesterday 150 gems… no excuses…


#3

@Petri Report of Update not working; gems still being lost.


@jenneee @Dudus

I do know SG made an announcement that gems would be auto-returned after the event.

This was also mentioned in the email sent to all players yesterday:


#4

Just to make sure, did you update your game to 1.13.5 when this happened? Only this update fixes the issue, not the earlier ones.


#5

Yes. This has happened twice. I updated my game when I saw an update. Later same day when I opened the game it wanted to force an update. It sends me to apple App Store but only option is to ‘open’. No option to update. So locked out of game. Check back several times with same results. Then later or next day it opens fine with no other update. Both times I was on the latest update. There must be a problem with how your code recognizes game version after update.

David Chupp