Update to v1.8 not available on iOS


#1

Hello All,
for some strange reason the game update to v1.8 does not appear in my App Store updates


Update trouble
#2

I cannot open the game now because of this. When I try it says good news update available and there is nothing to update


#3

i have same problem with Android. Just downloaded but update doesn’t start - i have free space on device


#4

В мене теж не відкриває на андроїді


#5

Same issue, I’m locked out of the game. I get the “Good news” message when trying to open the game. Hit the update link and it opens the app page in the store. The app page show v1.8, but has no update button. Only a “open” link. Hit that to start your vicious circle.


#6

And thus the apocalypse hit the world of E&P; not with a bang but with a logical loop!


#7

Hi, please try the following instructions:

  1. Close the game by double tapping the home button and closing the game by swiping it up
  2. Open the App Store and go to the Updates tab
  3. Swipe down to refresh the list. You should now see the Update button next to Empires & Puzzles app. Tap the button to update your game.

Nowa aktualizacja
#8

E & P tells me there’s a new update, push on it, takes me to Apps. But in App Store there is no update, only says “get” push on that and I’m back to the game where there’s the update sign. Please, I spent money, have a good team of heros and an Allience. I don’t want to reload and lose all that. :cry:


#9

What device and ios version? I still had problems loading new version for my ipad with new ios. It would just offer 1.7 version, not new 1.8. DO NOT remove and reinstall. It will not give you the new version.


#10

Hello. I could not even on 1.8. Update. my play store tells me that my device is not compatible with this version.


#11

I noticed in ios11 the update page doesn’t refresh itself very often, for me it worked to swipe down like Petri suggested, you see the rotating wheel and it refreshes after, I got the update then (this was 2 days ago, when some had it already on ios and some were still waiting)


#12

i just removed and reinstalled. all working now


#13

Thank you :pray: that worked!


#14

I can‘t make the Update and now my Account is away? How can i geht it back?

Please help me. I dont want to loose my Allianz children of the Moon


#15

On my iPhone, 1.7.3. Thank you


#16

But don’t you lose everything? If you remove and reload?


#17

Got it! Thank you :smiley:


#18

Thanks for your explanations


#19

This did not work for me and I unfortunately deleted my app, since I was stuck and had no other recourse in the app or App Store, only to realize that even though iCloud said it was backing up my app data, I was unable to recover the data. Now I’m back to square 1 after having spent a lot of money on jewels (username was Mordecai). Am I out of luck? Anything you can do to help me recover my original account?? If not u guess i’ll Move on. I can’t start over after how much progress I’d made.


#20

I would contact game Support directly:

https://smallgiant.zendesk.com/hc/en-us/requests/new82

Anything you can tell them about your original game (specifically account number, Version, Build if you know it) would be helpful.