Update issues x 3

  1. I only played the Legendary stages of the Quest game. Didn’t get loot.
  2. My game froze in the raid tourney causing me a loss with 0 points and my score showing Is way off.
  3. pretty pissed because I cant fight the current rare titan because when I hit the fight button I get an error message about not being connected.

[removed SS showing Account ID]

Well, obvious questions first: did you try to close the app, clear the cache and restart? Most of the time, this works for me in situations like this. At least the point discrepancy was solved that way… :wink:

I’m getting this error too.
I bought the offer. It didn’t show me the gems or coins so I closed the game. Now it says connect error

{removed SS with Acct info}

2 Likes

Have the same problem. Feels like Groundhog Day, cause I get the same error messages like yesterday…

Same here 20 connection errors

This is SG being SG…lol…they can never get this right lol…its so funny.

Cannot raid because it just spins the circle and brings up no opponent. Pulling at new event lagged for half a minute. Definite server issues.

Did they not foresee this would be a problem?

Connection error again? 2nd time this week.

Edit: the game is working for me.

guess what? I am getting the same “connection error”. Maybe it is a new feature for upgrading players patience and not a bug lol

Nice zero on the titan… Sick of this crap

Had this same issue, but clearing the cache and restarting worked for me.

Cookie Settings