UPDATE ICON not going away/Update Not Available

Update icon not going away, no update available, game on latest version from last night.

2 Likes

Did you check that your game is running the latest version 28.1.0 from your in-game Settings (under the About tab you can see your game version number)?

1 Like

I am the same. The store has NO pending updates, I have restarted the game about 5 or 6 times now. In the About, it shows 28.0.1 for me but even when I click the UPDATE icon, it takes me and says “open game” not “update”.

Edit:
Android / Samsung Galaxy S7

4 Likes

It’s same for me as well

Same here. 28.1 hasn’t reached my region yet it seems.

1 Like

Same here and in messages it says 10985 days left :wink:

That’s a pretty annoying icon when the update isn’t available yet.

2 Likes

Yes same here …Already updated two days ago according to my playstore. So no update pending!

Same here version is still 28.0.1, no update available yet for 28.1

omg that POV “9” icon would annoy me. Collect them already!!!

5 Likes

Same for me. Store shows no update available

Same issue here. In options it shows me on 28.0.1, play store shows that the game was updated 2 days ago.
Samsung Galaxy S8+ if that helps.

Have you tried clearing your Google Play store cache?

https://support.google.com/googleplay/answer/7512202?hl=en

By the way, we are going to force this update only after Easter holidays, so there is no rush to update.

2 Likes

Maybe no rush but the “update” icon is annoying to have on screen constantly, I think that is one problem for most of us.
The screen is already filled with icons for offers etc so this extra, unnecessary one is just an added nuisance

1 Like

This might help as well:

https://support.google.com/googleplay/answer/113412?hl=en

Update Android apps manually

To update apps individually or in bulk using the Google Play Store app on your mobile device:

  1. Open the Google Play Store app Google Play|autox18.
  2. Tap Menu Menu|autox18 and then My apps & games .
  3. Games with an update available are labeled “Update.” You can also search for a specific game.
  4. Tap Update .

Note : Some apps require new permissions when they are updated. You may see a notification asking if you accept the new permissions.

Tip : In some cases, you may need to restart your device to update an app.

1 Like

The only buttons that are available are uninstall and open.

1 Like

Clearing cache and manually update didnt solve the problem and i tried force shutdown application

2 Likes

Did you check your code before pushing the update? That’s where the problem lies, not in user behavior.

1 Like

I am having same problem. I cleared cache and tried updating using play store menu. No luck.

2 Likes

And I restarted my phone before I even checked here.

2 Likes

Cookie Settings