Update Available...but not on app store – forced update when using two devices, one on Android and one on iOS

did you update another device on which you play the game with the same account?

if so, you will have to wait until update appears for the second device too.

1 Like

I have the game on my LG G7 and my iphone Max, both are set to auto update. Game runs fine on the android, won’t load on the iPhone which is my primary device

Apple does not allow phased roll out.

So slow roll out on Android- cancelled if bugs found- followed by 100% roll out on Apple.

1 Like

Does this mean I can’t use the app on my iPhone until the update rolls out??

I have same situation on Android.
My smartphone got update and works fine, but BlueStacks with Android can’t see any updates.
Game not run on it, just writes that “new version is available…”

1 Like

Download Aptoide from your Google Play/Apple store, use it to download the update. It’s a legit alternative to the standard app stores and makes the updates available to everyone rather than phasing

then I was right.
I would advise you to disable autoupdate for the next update, so you may update when both devices can update.

Yes, you cant; unless you do this.


When you accessed your account from your Android device, it updated your server file to the new format. When your apple device tries to access you server file it crashes.

Hi, same here with android first Update and problems with Bluestack. Should I wait? Or do the workaround with Aptoide on Bluestack? Time is no Problem, because my Android Device works fine, i had only trouble on bluestack.

Yesterday there was strange situation. Was kicked from game when was in raid and Google Play was showing that something updating. But then it’s appears that there was no updates at all and game not updated at all. And no one in ally still have no update, so looks like update is stopped to fix bugs.

Also Google play showed my version of game as “old version” but still no update.

Same situation at BlueStacks emulator.
Solved by manual download and install E&P.ark version 19.0.0

Where do you get apk?

20 characters

Same here. Can’t play from my iPad because the update is unavailable

Don’t sure it’s allowed to publish this kind of links. So better edit your post. Only left name of the source to search in Google

1 Like

since a few hours, a new update is rolled out at it works at my bluestack.

Update done, but the game doesn’t work… no problem on others games or browsers…Screenshot_20190206-184629_Empires

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

When I go to the game it says there’s an update available in the playstore, but when I go there the only option is open. There is no update. I’ve tried the usual clear cache, force stop, restart device. Nothing works. I still have flags on war!! Help!!

Try checking the version you are running. Mine downloaded the update automatically. You may already be running it

This typically occurs because roll-out is staggered.

Check back in 30-60 minutes time & itll all be sweet I expect :slight_smile:

Cookie Settings