"Update Available" but no update in App Store (V30 -> V31)

Hello I can not get into the game as I do? It tells me there’s a new upgrade in store but there’s nothing port update on August 7

If your account is connected to Game Center or Google Play, delete the game and re-install.

I’ve already tried but nothing

Hi;

This often happens with the roll-out of a new version. Reason being is that Apple & Google Play stagger the roll-out to different regions over the course of a couple days.

As a result, there is often a short term disconnect (usually no more than an hour) between the message of “an update is available” and it actually popping up in the App Store.

For me, I usually resolve it by doing the following actions (only do the

  1. Force Closing & completely restarting the application

  2. If that doesn’t work, I force close the app, restart the device & then on restart, check for an update in the app store.

  3. if that doesn’t work, I simply wait a little while and try again with steps 1 & 2.

I’ve done everything but I can’t get into the game I’m crying who helps me?

I am not sure that your device is showing the latest game version for downloading already or not.
For me: version 30.0.3 build 771

Bring your own update but there’s a new store sign and it won’t let me in

@petri You can help me

If the problem persists you can try #contact-support

Nobody here on the forum is able to investigate specific account logs or anything… only support staff can do that (Petri is in community engagement; not support).

I wrote to the support I hope they can fix is a three-year-old accaunt liv 78 I wouldn’t want to lose the progress I just have this anyway thanks for the advice

1 Like

Good luck for you.
Level 78 is not easy to achieve
:smile:

1 Like

I would like to see the face of my heroes hopefully well already I miss

Streghettalis is your problem solved ? I have same problem on play store

Thanks to all problem solved SG

image
I can’t login in my account due to update pop up.
There is no update available in apple store.

Don’t update the boards have just gone ridiculously bad with it

I cannot even get that far, crashes at SGG logo, doesn’t even get to display the Elena/Richard/Layla background :sob:

Have you tried to uninstall and reinstall the game? It might help.

Not tried uninstall/reinstall yet. Concerned about losing 18 months of play (Level 55, stronghold level 25.)
Have rebooted phone and checked for v31 update.

Kiedy bedzie do pobrania aktualizacja 31


When will update 31 be available for download?

Cookie Settings