Unable to purchase Raining Loot Ticket Offer

I’m afraid I might miss out on this offer needing the gems as much as the loot tickets. I know money is not the issue, nor is it the card. Is the system having issues right now?

Oh my goodness! It didn’t let me buy it. I admittedly tried again thinking I would get different results…

Now, I have two pending charges for one In-Stock purchase!!!

I too am having the same problem. However, I have one pending charge to my bank account, but not loot tickets given.

Thanks for chiming in, and welcome to the forum.

Should I wait and see if the charges fully process before filing a ticket? @JonahTheBard @littleKAF @zephyr1

Anyone know best course of action?


I think you should file a ticket. I’m not sure if SGG can help or not as it may be related to google. I’d also check your statement when it comes.

You can also try restarting the app. I’ve been looking for similar threads and found this. They all say contact support.

Also, check this out.


I tried restarting the app and my phone. Still much of the same. I’ll contact support and see what they say.

1 Like

Do check out the website. It’s SGG’s customer support site.

Thank goodness! With 16 minutes to spare! Must’ve been a combination of server issues and other stuff. We’ll see if I get charged $45 for this!

And it looks like the charge is only showing up once on my Google Play account…

Wait. I spent $104 in three weeks on this game?!!! I think I might not be as c2p as I thought I was.

i’m having a similar issue when trying to buy the vip pass.

Just tried on wifi and LTE

1 Like

quel est le problème alors ? il y a un lien vers une page ou autres ?

Je pense que c’était un problème de serveur. Enfin, j’ai essayé plus tard, et cela a fonctionné.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings