Unable to Connect with Game

I haven’t been able to connect for over an hour. Just wondering if other people are having similar issues?


So do i here, i think that’s only me…

Same here unable to connect to the game. Tried many times but still fail to connect.

1 Like

Hey me too :sweat_smile: +20char

1 Like

Me too. Thought it was my WiFi.

Nope. Rebooted wifi. Devices. Checked other games.
All good. Only EP is down.

1 Like

Network connection error again?

I’m wondering whether it’s only affecting Singaporeans players since Blackzed, Shere, myself and my local alliance mates been having the same issue for hours.

Playing from Singapore as well, constant connectivity issues.

Same problem here Thailand

Could be a “localised” AP issue.

I am okay using 4G. Wifi doesn’t give a stable connection.

Home wifi is with Starhub. Starhub had maintenance in the early hours of 29/1/23. It could be due to that.

Usually experience connectivity issues post Starhub maintenance.

If it’s “widespread”, it could be a problem with one of the underwater cables. Not clued in on these logistic arrangements.

My WiFi is with SingTel and it’s working fine. I also have 4/5G. However, connectivity issues persist.

GF plays mmorpg. Can’t log on too.

It’s a weird situation now.

Starhub too but still can’t log in

wifi takes forever, mobile data loading very slow. we’re having war now… fix it !
dun just throw a red energy refill as compensation again

Im having issues too.


I’m wondering if this is an EP server issue. Like during W3K when servers were overwhelmed?

It is working for me in Europe.

Anyway I have raised Staff"s attention to this.
But as it is weekend I am unsure if they will answer in time.

Try to directly contact support here:

1 Like

Probably the weather issues. It’s has been hardly to catch the sun for awhile.

I also had this issues, and I could not find an answer on this forum, so I decided to chechk the advanced internet settings on my phone manually. After chechking them on the website of the provider, some settings were different then adviced. I changed them, and now the problem seems to be solved.
These are the settings I am talking about:

Maybe it will help for you guys too. Good luck!

1 Like

Thanks so much @PlayForFun. I will report it.