Trying to buy latest special offer


#1

Atlantis Offer. I’ve been waiting half a day for my £1.99 purchase to go through.


#2

Same here. I’ve had it open for half a day and it just stays on the purchase processing window.


#3

I am having the same problem. It constantly cycles without approving the purchase. I have purchased in the past so an update must have broken it. I have tested as of October 4 and it is still not working after a reboot of the iPad.


#4

I’ll tell you how I fixed my problem, I think it’s a cache problem.
I just signed out, deleted the app, re-installed the app then signed back in and opened the app again. The purchase was already there and I just tapped on “Claim”.


#5

Tried that out and didn’t work. Thanks for the tip.


#6

I think its a random to apear special offer.


#7

It happens for all purchases of any type so it is not just special offers. I currently cannot purchase anything from the store.


#8

I havn’t been able to get into the store all day


#9

2 posts were split to a new topic: Purchased cards are level one