Titan a no show

Hi for some reason the titan has not been showing up on my map the last couple of days even after i get a notification saying a new titan has appeared this has happened for about three days now

Titans appear in different corners of your map. When you first get a notification, look on your map, lower left. There should be a red dragon head. Click that and the map will shift, centering on your new Titan.

Note the location, because the dragon head only appears until you click it. After that, you will have to manually locate your Titan.

Let me know if this helps. :wink:

And there is another way to access the titan:
open your alliance overview.
You can see the members, and to the right of it, it says " Titan". Click on “Titan” and access the current titan from there


Maybe, you should get an alliance ))))

Do players get a “new Titan” notification if they are outside an alliance? :face_with_raised_eyebrow:

No, mam :wink: They don’t )))

Then OP is dealing with a potential glitch or other. :wink:

I am in an alliance, and when i goto the map the symbol for a new titan doesnt show up either, and even in the alliance tab it doesnt let me goto the titan


I would recommend to contact support

I tried the support button and it took me here

Two things:

You can also find your Titan by clicking the Alliance button at the bottom of the screen, then click Titan at the top, then clicking View on the pop up box. _ SEE EDIT BELOW._ (Click Next to start attacking…if you are in between Titans, there will be a question mark in the pop up box, and a timer telling you how much longer to the Titan.)

Apparently, if the Titan is dead, you’ll see “View” as above ^^.

If the Titan is new and attackable, you’ll see “Attack”:

To contact Game Support, read this:



I tried the alliance tab when it said a new titan appeared and this is what i got

Im trying to see if removing the game and redownloading it helps, i have my progress saved on google play

Had the same problem, it disappeared after restarting the game a couple of times. It appeared after updating to 1.9.8 build 550.
The big problem now is that I can’t start missions / quests.At the point where the energy points are substracted to start the mission, it shows a rotating circle for some seconds, shows an error regarding the connection to server and return to main view of my base.
I tried WLAN and mobile connection, even reinstalled the app …

Have you tried to exit the alliance and enter again?

I would definitely contact Game Support in your case; it can’t be “Titan ?” indefinitely.


Cookie Settings