The game tries to update but I cant update and I cant enter the game

Every time I enter the game he forces me to update. When I try to update it gets stuck in a loop by “pending…” as seen in the attached photos. I try to restart the phone but it gives the same result.


the sad thing is I tried to send a ticket for help but the system automatically closes my request because “I do not fill in all the details” even though I do fill. I have no way to contact only here. please help!

I think it is a Google issue and not a Small Giants issue.

Do you have enough free space on your device ? (At least 850 Megabytes are needed to update the game)

Maybe you can also try:

  • Clear Google Play store’s cache
  • Restart the Phone
3 Likes

Another possibility is that it looks like it is trying to update by downloading via network data as opposed to WiFi. I know there are some settings in Google play to only allow download over WiFi. Is this possibly a reason?

1 Like

Thanks guys for your reply!!! Its solve itself. I have no idea what cause this and I have done nothing and it suddenly start download the update. I guess its related somehow to the connection issues earlier this day. BTW Kilted I am aware that my WiFi is off, My WiFi doesn’t work properly but I gave permission for android to download without it :grinning:
Thank you for noticing this.

4 Likes

I am happy that your issue is resolved itself.

1 Like

It was 156MB from memory. I logged in. the game started and the update available icon was there. I just clicked on it and it just worked automagically and relaunched.

I do not know why, but for me I need about this 850 MB of free space to perform any installs /updates in Google Play even if the program what I try to install is 1-2 MB.
It downloads successfully if I have less space, but it will fail at installing.

I’m confused now too. What version of Android are you running and on what device? Almost a gigabyte needed seems extreme to me. My phone and emululator show almost identical characteristics. I can’t speak for iOS as SG have blocked me at Apple game centre.

My phone is using 4.4 Android version.

The same, the update requires 102 MB (my bad for the error) of download space but I certainly don’t have 850 MB free.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.