The app is crashing like crazy v32.0.0

I’m using iPhone 7 iOS 14.0.1 and since the latest update the game is crashing when:

  • typing message
  • fighting titan
  • fighting in raids
  • doing missions

Please fix this mess because I’m afraid to do my tournament points. Thank you

Ok, I can’t even fill my monster chest because of the app crash 3s after starting a fight

I am running into the same issues!

I lost one green 3* trainer hero when I was trying to feed my yellow 5* with two yellow 1* and 2* heroes.

Uninstall it completely and reinstall. I’ve had that happen once after a big update.

Me 2… raids and maps

I have uninstalled and reinstalled as instructed several times as it has not worked. Now on my cell phone the game reverted me to the beginning as if I never played the game. I am still not able to participate in war, tournament or even the Ninja events in any consistency. I have to use my tablet and I refuse to uninstall and reinstall after what happened with my cell phone. Please advise.

My tablet also does not connect to the game with any consistency. I often cannot connect and if I do I cannot play.

Glad to know it is not just me.

Same here. It crashed during a war and I ended up with a score of 0 :frowning:

Edit: I’m using Android on my tablet.

Same here, during war crash and closed, 1x flag used and 0 point, I hate this… I guaranteed almost win only need some tiles… Crazy… :man_facepalming:

EDIT: Using iPhone

EDIT2: Not only in war, it also crash while in maps (I’m not sure how many WE used without any reward while I’m in Seasson 3 to get avatar mission, 8xWE on each crash,… :man_facepalming:).

The game is also crashing on my slightly older iphone devices.

From about version 30 it started crashing on my older ipad mini 2, but was fine on my ipad pro. I raised a support ticket and they investigated but the eventually shrugged it off suggesting I have device problems.

I had rebooted, upgraded, and re-set the Ipad multiple times, but the game keeps crashing and getting worse with each subsequent release after v30. Personally, believe it may be something to do with the size of the game, memory problem or something with all the new features (but not sure of course).

Hopefully @EmpiresPuzzles might lookt at this more seriously now…

1 Like

Cookie Settings