Stuck on 'connecting' screen

I couldn’t find a topic on this that was recent. I saw people commented on an old thread, sorry if I should have done that instead.

For the past 24 hours or so I’ve been having trouble logging into the game, it just sits on the “Connecting…” screen. I’ve never had a problem before this and have been playing the game for a month or so.
It started yesterday and after finding an old post suggesting to turn the phone off and on again, I did that and it worked. That trick isn’t working today and even after shutting it off and on a couple of times it still just sits on the “Connecting…” screen, refusing to load.
I have the game on my android phone. I made the account just to ask for help since I couldn’t find anything after looking for some time. I saw people had issues like this with the 16.0.1 version and the new update was supposed to fix it. I didn’t get the problem until after I got the 16.0.2 version of the game.

Sorry if I shouldn’t have made a new thread, but I wasn’t sure if threads from months ago would be the exact same issue. Thanks you for reading.

1 Like

After turning on and off my phone a couple of times, it worked this morning then just had the same issue again now. I saw there was an update so now I have version 16.1.0. I rebooted my phone and it still won’t pass the connecting screen. :frowning:
I don’t know what’s wrong with it since I never had any issues before the 20th.

Try to check google play store for updates.
If you are not on the lastest it wont let you in.

If you sure your progress has been sync to your google play center you can try to uninstall then reinstall

BUT JUST IF YOU ARE SURE OF SYNC.

I went to google play and have the latest version. Everything is up to date, but even after rebooting my phone a couple of times, it still won’t log in. :frowning: It just gets to “connecting” and won’t go further.

I don’t understand the sync thing.

Edit: Restarted my phone yet again and it still won’t work. :frowning: If it’s not going to work sometime soon I might have to just delete the game, even if I was enjoying it. No point having something I can’t access :frowning:

Edit 2: I don’t understand how to know about if it’s synced. All the other games I have work. I’m afraid if I uninstall it, I’d lose everything. :frowning:

I’d recommend you contact Small Giant’s support directly using the link below. To create a ticket, click on submit a request. I do also recommend using the sign in feature on this site. It will allow you to go back and review status of current or past support tickets.

Good luck Ashleyien!

https://support.smallgiantgames.com/hc/en-us

1 Like

Thank you.
I just filled out a ticket. Hopefully the issue will be fixed.

I was told to try updating to version 16.0.2…
I have what Google Play says is the newest version: 16.1.0. Isn’t 16.0.2 an older version? I’m pretty sure it is…
I have no new updates available for the game.

I replied 12 hours ago and am still waiting for a reply. Right now I’m just hoping there will be a new update and with it I can access the game again. I’m getting quite frustrated with it not loading :frowning: I don’t know what else to try so I just need to wait.
I also don’t know if I’m the only one that’s having the issue of it not getting past the “connecting…” screen. I’ve seen lost accounts or missing building listed as issues but no one else seems to be having the same issue as I am.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings