Spring offers-purchasing issue or bug

I tried to buy the offer for today and it just sits on purchasing. It sits there for 1-3 mins then closes out the offers. Anyone else having this issue? I tried well connected to Wi-Fi and not connected to Wi-Fi on cellular. Is anyone else having this same issue? or does the game just hate me lol and as you can see I just need 1 more telescope.

.




NOTE: I didn’t even try to buy this offer but I noticed it in the corner and when I clicked on it it to says purchasing but I did not try to buy it. @Petri

Same issue as above just hangs

are you on iphone as well?

I did see this in another thread …

Could just be a iPhone issue when some apple stuff was down…

Side
It dont look to appling to be a apple customer whilst trying to purchase items as that be appalling … If the issue is fixed with apple we should give them a round of applause for sorting it … Maybe apply a support ticket if the problem continues …

1 Like

That went through later on yesterday but today I try to do the heavenly treasures 3x and it only let me do 2 and when i went to do a third time it said this in at purchases already been bought. I only brought 2 and it wouldn’t let me buy the third one. then i clicked on the other offers and it showed same thing as yesterday purchase in progress for items I wasn’t even trying to purchase. @Petri Is this cause there’s too many offers going at once ? I currently have 5 offers at once going right now



In my different games I don’t have this issue with making purchases.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.