[SOLVED - V30 Update] Mothernorth and alberich trouble working together

As I understood the game right it doesnt make a difference how many pause I make when firing heroes.

For example I normally tap quite fast and never had an issue with it. So when i push vivica with costume and direktly shoot seshat, even though vivicas optical special is still in progress the damage os calculated right.

What happended?

  • I tap MN first and then Alberich (quick)

What should happen?

  1. Mother revives with minion, then alberich mana and regenerate triggers
  2. Mother does nothing, alberich revives with regenerate and mana
  3. Nothing happens.

But what seems to be IMPOSSIBLE is that mother revives and no alberich regenerate/mana triggers.
Because at first I fire MN and then IF she revives, alberich would guarantee his buffs.

If I wait for the revive of MN, alberichs buff will be set.

But this seems to be a bug as normally you dont have to wait for heroes to have their special be finished.

Are you 100% certain you hit MONO before Alby? You said you hit the specials quite fast…

Maybe you hit Alby first then Mono & hence resulting in Minion but no regeneration

Happy bDay @Enni :slightly_smiling_face:

Alles Gute :moon_cake: :gift:

Yes @Guvnor 100% sure and made a video of it as it is reproducable. :slight_smile:

Edit: Video MN and Albi Trouble

Here is the video. I think its clear

Edit2: thanks @Olmor !

I had a similar issue the other day with MN and Tarlak. I had a full green stack MN, Peter’s, Evelyn, Lianna and Tarlak fighting a Titan. Peter’s had died and the remainder all had full mana. Firstly I fired MN in hope of reviving Peter’s, followed by Tarlak, Evelyn and Lianna. Peter’s did revive but when I looked he did not have Tarlaks buffs like the others. I fired the specials one after the other without a pause and before any other turns had checked Peters so I can only assume I fired Tarlaks special too soon after MN’s.

Yes, seems to me that with resurrecting heroes you should always have to wait until the heroes are “completely” alive.

Still i find it very strange and recommend to have this fixed.

Thank you for reporting, I am marking this as a known issue and it will be fixed for V30

Marking now as SOLVED per the V30 release notes :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.