[SOLVED] Unable to Use Golden Emblems to Learn a Talent, Citing a Lack of Resources

Yes I did yesterday but still no response. How long does it normally take?

For a response via support? Probably a few days. If you are lucky they answer within a few hours, but especially now with the weekend it could be till next week. I have already experienced both time frames with the support.

For an answer here in the chat? From hours to weeks and sometimes there isn’t a final answer in the specific bug thread at all and it just gets implemented in the next update and mentioned in the release notes.

For a fix? Most problems get fixed with the next version after they receive the problem. Some easy fixes which don’t need a update can happen even faster. And than there are those problems who need endless. I’m not sure if this is record, but Alfrike hitting dodgers needed over a year to get finally fixed and was postponed from update to update :crazy_face:

2 Likes

Thanks Ferg for the info. Hope this one doesn’t take a year - really want to fully level Mr Pengi!

3 Likes

I didn’t think that far TBH :slight_smile:
Curiousity rules…

For me i couldnt add a 2nd gold emblem to any hero after 1st.
And now cant add norm emblems to the ones i did.

Should i just reset all the emblems and try again again ?

It is a bit different than OP (Golden emblems can not be used instead of normal), but it is similar.
If you can wait few weeks, then I wouldn’t reset as I suppose Small Giants might work on some fix on this in V45.

Do you have enough ham and iron?

Although you don’t need it, I have seen posts here that golden emblems doesn’t work if you don’t have the amount you would normally need for this emblem node.

We will have a fix for this issue coming soon in the next update (Version 45). Thank you for the reports and my apologies for the issue!

3 Likes

Dear devs,
Hi, hope you’re well after the holidays!

There’s a possible bug with golden emblems.
Please check the video below - player failed to get 20th emblem level with a golden emblem.
Player has 1 golden emblem, 1097K meat & 90K iron.

Video: golden emblem fail - YouTube

Possible cause - no meat/iron is taken when you up a hero, but there could be a hidden check if player has some amount of meat/iron.

@Gabteeni , @Petri

Kindly ask to investigate.
Thank you!

P.S. All the new items are GREAT, thank you! :+1:

9 Likes

And as I see he didn’t had enough emblems as well.
Maybe @Dudeious.Maximus / @Guvnor can send this to mod chat.

2 Likes

Have flagged for Dev/ QA attention.

3 Likes

Nope, I believe it’s not it.
Here’s an example were insufficient amount of emblems wasn’t an issue.

It seems to just be a case of the Golden Emblem not ignoring all the background “checks” before applying.

Seems the devs coded in to ignore the emblem quantity check but not the food/iron ones.

2 Likes

As I am not understanding Russian I have just noted what I saw (25 emblems Vs 250 or 247 Vs 250 on the second video).
But yes it can be just some food/iron check.

Thank you for the report, we’ll investigate this here.

4 Likes

This issue will be fixed in the next update (version 45). I’ve now marked this topic as a known issue.

1 Like

Thanks Petri for the response and fix.
I guess my Hanitra will have to wait :slight_smile:

2 Likes

I’m having the same problem! Glad to see it’s being addressed!

1 Like

This issue has been fixed in the latest update (Version 45). I’ll mark the topic as solved.

Per release notes:

  • Fixed a bug with Golden Emblems in which the game would prevent players from using one to learn a Talent, citing a lack of resources
4 Likes