[SOLVED] Quests changing with hours left on timer


#1

Both of my quests just changed even though they had several hours left (not sure exactly how many but more than 5). I was 10 minutes from having the energy to finish mount umber when it randomly reset.


Quest reset/titan bug
Update bugs
#2

You not alone)
The same thing)


#3

Yes, I noticed too. I was very glad I decided to finish mount umber this morning (I was actually planning on finishing later).
@Petri Serious bug!


#4

I just made a topic about this too. It really sucks. Ascension items are already hard enough to come by. Im not a complainer but dang. I was just waiting on flag replenishment and now that I have the flags I have no quest…


#5

Hi, apologies for the problem! We have now resolved this issue and brought back the quests that expired too early.


#6

Thanks for the prompt fix! :slight_smile:


#7

For some players the quests changed and they lost Umberberg many hours before it should expire.


#8

Hello. I have faulty quests.
Mounst umber is still 6h35 '. I did not hit the game then did not see the Quests anymore. ACCOUNT:
Please help fix you with, because this mission reward is quite important :frowning:


#9

It is back. Try close the game and open again


#10

What happened to the rare Mt Umber quest? I should have had quite a few hours left to finish it this morning but its gone. I finished all but the last level and was just waiting on flag replenishment. Now that I have flags I have no quest to finish. It was replaced by an xp and gem quest. Normally I wouldnt care or complain but I need the mystic rings. Ascension items are hard enough to come by already…

And the 0 titan score glitch is still going on. I fell victim to it this morning. That one sucks but I can make up for the lost points. I cant make up rings.

Screenshot_20180302-053034


#11

I have the opposite I have the quests from yesterday and two new ones


#12

I do too now. They fixed it. I got my rings. :smile:


#13

Just before the 4 visible quests i only had 1 quest.

Often after switching back to the game these bugs seem to apear. Double titan is another example. Allience chat disapearing or just the playerchat disapearing.

The last update seems to have improved the rate of these smaller bugs


#14

I woke up to the same thing. So I finished them before they were taken just in case.


#15

Umber is back. See Petri comment above where they fixed it. :slight_smile:


#16

@Rook not complaining at all. I would :heart:️ if they kept this many quests so we can have a better shot at much needed ascension materials.