[SOLVED] Oct 22/21 Mystic Vision issue with ads not closing/giving rewards with certain ad

The TURO advert plays. The normal 30 seconds pass. The screen changes to the prompt to get the app. Hit the X to leave the advert and it’s as if mystic vision was never watched or you exited to soon and have to watch it again. I left it up for 1 minute after prompt screen. Still nothing. I’m not watching that advert again. 8 times is enough. PLEASE FIX

6 Likes

I watched the video, clicked the fair app to check it out, but now I can’t get credit for the vision. It just plays a shorter version when I view it again but nothing happens. Should I not visit your sponsors anymore? I already exited and restarted app many times.

2 Likes

I am also having this issue. When watching the video an x comes up that lets you close out early. No rewards are given if you hit it early and no rewards are given if you wait until the video is over and hit the x. The commercial I have is dungeon and heros.

1 Like

I’m having the same issue. Dungeons and hero’s. Watched 6 times now. Restarted the app, my phone. Deleted the app and reloaded. Doesn’t work. Also my dragon squawks when being shot, no more arrow sound.

I’ve watched the same video (Quick Books) over 6 or 7 times this morning and no matter if I wait 1 minute or 5 minutes to exit the add, it does just that, without giving me my daily prizes. Any thoughts? Tried exiting and restarting, but get the same ad that will never end!

1 Like

I’m having the same issue with the Fair car ad. In Mistic Vision. I’ve payed it a half dozen times. Won’t give me whatever reward (hopefully a very rare ascension item) and won’t go away. Yes I have updated to the most recent version of the game.

I am having the same issue with Mystic Vision.

Same here. Raised a ticket for it - I must have seen that mystic Vision 20 times now without being able to clear it.

Same with me. And I’m sure that it wanted to give me the royal tabard I need to ascend Hel, plus some other rare ascension items!

Here’s another one. I get the turo’s add. It has some decent music so I was cool watching a few times but would rather have my mystic rings :joy::rofl::joy::rofl:.

By the way for you all getting dungeon & heroes, I did not enjoy that game.

I’m using an iOS system if that matters.

I do not get credit for watching the ad after I watch it then exit out. The ‘Play’ button still appears and I get no loot. When trying to watch again, the same ad is played back and I get no credit again.

I could not find any posts (for version 16) related to this issue.

Did you close app and reopen and try? There was also another small update, may need to do that.

Hi Heat. I had the same problem. I logged out and reset and everything worked fine now. :slight_smile:

Mine isnt working either … tried logging out and back in and still having the same issue :frowning:

I also tried resetting the game and my device, still stuck in an endless loop of videos with no rewards. The play button will not disappear.

Same, hard restart of the app doesnt change anything. Been watching a lot of commercials now… i expect a very good reward by the time it works again :slight_smile:

  • update your game to lastest update.
  • remove the app cash, then re-open it.
  • restart your device and male sure your connection is strong enough for M.V.
  • wait till the video timer get to 0 before exsit.

My video keeps resetting, I’ve looked at the other threads on here and have followed the suggested steps, no reward no error code but it keeps giving me the video I watch along with the no reward…what do I do next?

Same issue here, and yes I have cleared cache, hard closed game and reopened, waited til ad was done to close…

I installed the small update and then closed and reopened the app. Still having the same problem.

Cookie Settings