[SOLVED] Nasty glitch in Sand event

Advanced level 17

This one was worse level 20


The dead enemies stayed there too
Android

I finished the Advanced difficulty first and haven’t encountered such glitch. However, I have issues when relying on the Magic Hourglass and Magic Lamp as some or all the bosses are not affected on the delay (their mana is not grayed out) and they still are able to attack even immediately after the Lamp and Hourglass was activated, sometimes stacked.

3 Likes

@Guvnor can you help us somehow? :slight_smile:

Only advice I can offer is:

  1. make sure it’s not a client side issue

    • restart device,
    • restart app,
    • switch from Mobile Data to Wifi (or vice versa) &
    • Clear Game Cache (ONLY IF YOU HAVE SYNCED WITH GOOGLE OR APPLE PLAY)
  2. Create a support ticket in game (click this hashtag for instructions #contact-support)

2 Likes

Does anyone have strategies to clear your troops off the board/screen? Lol… Experienced my first glitch in EP


Was getting this glitch earlier, as well. Decided to restart the device I was playing on and then didin’t have any issues. Thought I wasn’t going to be able to complete the level I was on because couldn’t get to the top 3 rows of tiles or so :persevere:

Thank you all for reporting this, I have now passed this thread along to our QA team for a closer look.

3 Likes

I had the same problem back in Feb with the trials, not as bad as yours though


Same problem for me. I think triggering 2 hourglass and/or lamps triggers this. Does not appear to hang, i can still play but it will be problematic at more advanced stages. Aside from the troops freezing, the dead minions also stay. Makes targeting with special skills hard.

I got this too. Fortunately on my final move though. (Easy 20)

Thanks to your reporting, we located this issue and are now actively investigating. I will update as I know more. Thank you in advance for your patience while we work on a fix.

8 Likes

happened to me but only on the last level of Legendary… As you can see i still won due to Wilbur and Azlar using their special before the glitch happened.

1 Like

After restarting the game/my phone it does not seem to happen again… how about you guys?

1 Like

I am getting the same thing. It’s making it impossible to play unless you put it on Auto

2 Likes

Thanks, Meangreeneagle. That is a good tip. I could only see the bottom 2 rows at a certain point.

1 Like

I have had this issue several times too!!! Maybe 8-10 times so far, closed down the app and restarted my phone multiple times, but as soon as I think the glitch won’t show up again, it does. I was able to win most times, but 2-3 I specifically lost because of the glitch. Extremely frustrating! The advanced stages are pretty expensive in regards to world energy and used battle items, this is something SG should compensate for!

2 Likes

Hope you fixed it soon, I restarted my phone, the app, switched from wifi to data, cleared memory and still I have problems, it’s clearly related to the game. I don’t know if this is related but I notived that most players with this problem had teams with heroes with minions.

1 Like

Had the same problem earlier, it was on normal stage about 18 or 19. I was able to finish the stage but the screen was a bit messy

1 Like

Subtroopical Military Parade :wink:

I had lots of minions without any problems.

Looks like an overlay freeze and could be related to some graphic chips or rendering routines.

1 Like

Cookie Settings