[SOLVED] Nasty glitch in Sand event

Hello guys, so this is a member of my alliance and he recorded his attempt on the last stage of Sand Empire. Don’t know if this is common and if anyone can explain this :slight_smile: the problem with Ranvir not being able to gain Mana is also there, so just please share your thoughts…

7 Likes

Has it done that multiple times?

I had a similar problem. Troops were freezing on screen to the point you can not see the board any longer. Happened on multiple stages in normal and advanced. I was not having the mana problem but couldn’t finish the stage.

2 Likes

@Petri

Somethin seems to be screwed up here…


I have it at Stage 19, 20 normal and hard

2 Likes

Looks like a bug with the game.

1 Like

Lol was this sarcasm?

3 Likes

@zephyr1 if you could contact someone from SG would be much appreciated, it seems more common than I expected :slight_smile: Boldtusk also didn’t gain Mana at 17s.

2 Likes

I had the same problem

I was able to finish the stage with bombs though.

2 Likes

I too have this problem, once I experienced it, it has reoccurred every time since… makes playing the board almost impossible!!
image|281x499
I am on iOS

1 Like

My buddy is also using iOS, seems like we found a clue to what’s wrong…

2 Likes

I’m on Android

20 glitches

2 Likes

My account, my wife, my daughter. All having same issue.

Seems not to have anything to do with own heroes.

Its just heavily glitching. Seriously, THAT should get some kind of apologize.

1 EHT and 1 flask of world energy and some words from SG that that was a major glitch.

Its really uplayable and a game like e&p lives from running fluently and nicely.

@ToL1 maybe change the title to “nasty glitch in sand event”

1 Like

Yes … it happened with me too …

Hi, I’ve been experiencing a bug during one of the level of the quest

.The game freezed and I couldn’t continue. I lost the energy and also the bonus of the level although I would have won. I tried to attach a photo of my screen during the fight.Hope you can see it. Please do something.
I want to mention that it happened the same thing during the previous levels but somehow the game still worked and I could finish them.
Thank you

Unfortunately you are not alone experiencing this issue. :frowning_face:

The game only appears to be frozen, I bombed my way out and won.

All the summon portals working fine though.they do something right @KiraSG

Advanced level 17

This one was worse level 20


The dead enemies stayed there too
Android

Cookie Settings