[SOLVED] Mystic vision not working 06.12.2020

Anyone else having trouble with MV?
When I tap on the vision icon, everything starts just as normal. The comercial runs, at some point the “x” apears in the upper left corner, taping it, ends the comercial, but no reward screen is triggered. It takes me back to base screen where MV icon is available again, but does nothing when you tap on it. Restarting the game resets the cicle that unwinds exactly as before. Restarting the phone has no effect either. Another thing, there’s no visible timer on the comercial, even if you tap the screen.

7 Likes

4 times I’ve watched the ads they’ll end and no rewards but I can close the game and watch another and get the same result

All good for me. But I have some team members facing the same issue.

1 Like

I’ve got the same problem and after I try to see the vision, my game is with no sounds

It’s this advert that doesn’t generate rewards

2 Likes

I got something very similar looking, called “Adventsmarkt”, I watched it 3 or 4 times without reward.
You can report the Ad, and after reporting I got a different which worked

2 Likes

I put in a support ticket. In the meantime I’m hiring the bad ads so hopefully I won’t need to close my game as often.

Same problem here since 10 hours ago, 6 Dec 2020

Video does not generate rewards.

Yup I’m also having the same problem.

Same here for the last 3 days . Tried below but nothing worked

  1. cleared cache
  2. restarted phone
  3. switched between wifi and cellular
  4. force stopped the app

Nothing worked .

Aqui está com o mesmo problema, assisti a propaganda e não vêm a recompensa!

Same problem although different ad to others. Restarting game and device had no effect

This is the solution guy’s

There is no “solution.” It’s the format of those particular ads. They don’t work. Keep rebooting your app until you get one that doesn’t have the “Learn More” at the bottom. I had to do it 6 times.

1 Like

There’s one for leap frogs, leggings, tshirts, all sorts of things, but they’re all that same formatted style.

Yikes. I starting “hiding” them and it seemed to help.

Guys the problem with mystic vision were you dont get rewards for watching ads then it freezes and mutes the sound on your game the solution is to report the ad then close your game then reopen it mystic vision should work fine then I would have put this on my thread but it has been closead

Thanks try this method a few times and mystic vision now works

1 Like

It’s only with the new “Learn More” style ads. They need to quit using these ads because they’re not working. Chances are your mystic vision only worked because you got a different formatted ad the next time. I got the same style 5 times before I finally got a different one that worked. I have a video if any admin would like to see it but I can’t post it here.

1 Like

Cookie Settings