[SOLVED] Missing advanced building missions (Fixed in v27)

I run two accounts. One of them has missions relating to 'raise an advanced (building type) to level (n) ', whereas the other accounts have no such missions. Are these random? My partner doesn’t have them either. In fact this account has a LOT more missions showing, despite being newer. No, I haven’t actually cleared them on the other accounts.

The Missions are the same for all accounts.

This article on the “unofficial wiki” has a list of all the Missions Available to players.

What I think has happened is that you have cleared all the early missions & just don’t fully remember doing so/ collecting the rewards.

It’s worth noting that the TIERED missions only show the current one (not all of them). So things like the Advanced Iron Mine & House ones will not appear until you have done all the regular Mine & House ones…

If you are SURE you haven’t cleared the missions I would raise a support ticket by contacting game support (see HERE for how to do that)

1 Like

This is definitely an existing bug!

As you can see i have no advanced food storage mission. Have neither had iron storage or any other advanced mission regarding advanced buildings.

Again, if you believe it’s an issue contact support:

Definitely! But as more than one person/account is afflicted I think we should spread some awareness about the issue? Free gems is free gems!

Yes, it is definitely a bug, but one that only affects some accounts. I shall report it, but maybe other should too. People would not know they were missing these missions if nobody told them … how can you spot things which are not there!

I only found out recently because just ONE account has them.

I honestly don’t remember having missions like that but doesnt mean I didnt. Is it possible you completed them with out realizing it?

1 Like

Yes, this is definitely an ongoing bug, because one of my friend was mentioning this exact thing a few days back :slight_smile:

1 Like

If you complete one, another one (should) pop up … hence the ‘upgrade stronghold to level 25’ mission, which isn’t even possible. I SHOULD have advanced farm to 10, advanced mine to 10, advanced house (for recruits) to 5, and maybe others … I should have passed the ‘advanced farm to 5’, etc, but didn’t ever see them.

It is broken … but not for everyone. Maybe it is tied to some other quest somehow … complete x fog stages, kill Triton twice, and stand on one leg while hitting a green Titan … who knows. 8>.

SG just replied to my request so we’ll see how this goes. Seems like what I got was an automated answer, even if signed by a staff member, since they asked about WHEN this problem occurred first and asked for thee screenshots I had already sent them… Will keep you updated!

1 Like

If you’re really lucky the next response will be that they have a lot of players, so if it was really a problem they would have heard of it already!

Because that’s EXACTLY what they told me about S2 hard missions failing to record wins correctly in rare cases.

Thanks for the encouragement :joy:

I got the same automated reply, indicating complete lack of awareness of what the issue was… Like ‘what was I doing when it occurred’ and ‘what color socks was I wearing’. No, sorry, made that up, but it is equally relevant to the issue.


I have a level 21 stronghold with a mission “Expand your base V - Upgrade Stronghold to level 25” Progress 21/25.

I also have -
1 Advanced Mine - level 6.
1 Advanced Farm - level 4.
1 Advanced Iron Storage - currently upgrading from level 3.
1 Advanced Food Storage - level 3.

I have NO missions to upgrade any of these 4, neither do I recall seeing any. It is possible I missed them but highly unlikely.

Anyone have screenshots of these missions ?

Looking forward to seeing where this one goes.

Missed my Advanced House (Level 2) from the list. No missions for that one either.

So you should at least have advanced iron storage to 10, advanced farm to 5, and advanced food storage to 5.

The others you’re ahead of me, but I can certainly guess at the missions…

OK, I’ve checked the “unofficial wiki” which Guvnor linked to in post #2.

If I’m reading that correctly I am missing 5 active missions and have “missed” one milestone (Adv. Mine to level 5).

Now to check all the other missions…

Full Mission list.

I never had any advanced building missions either. Possibly too late to do anything about it now though :frowning:

Don’t know if it makes any difference but I’m on Android 9, phone not tablet.

Cookie Settings