[SOLVED] Dragon Scale Showing Up in Alchemy Lab (V56)

Hey all,

A couple of my alliance mates on android devices spotted a new ascension mat in the last stage of the alchemy lab.

Anyone have any clue what this is? I didn’t see anything about a new ascension mat in the update notes.

This is on an official, non beta client of the game.


I would assume it has something to do with the alpha aethers, maybe? What happens if you click on it (does it give you info when you mouseover it?)

can’t press on it/select it unfortunately, just like if you were to have 0 of another mat.

It looks like dragon scale, old material from early times of this game. Useless and removed long time ago.


Looks like it could be an Alpha aether.

This is good news cos it means players can transform excess regular 4AM to Alpha aethers. For the price of 200 gems.

1 Like

Looks like you’re right, I did some sleuthing around the forums.
Now to find out why the code is back in the game. Must have something to do with the second LB I’d think.

Maybe they added it and will modify it after to become the Alpha Aether?

1 Like

More likely they just used the removed item’s spot in the code for the new item and forgot to update the graphic for it. Be kind of cool if the people who had the old Dragon Scale end up with a bunch of Alpha Aethers for their trouble.

I think its related to dragons dominion
Mats to ascend your pet dragon
Not supposed to come in this version
Its only hidden in the game data “unity”
Its a glitch
They may remove it in the next patch


Looks like a bug that activated an old item. Or maybe it’s being repurposed.


Thanks have asked staff to have a brouse at it


It looks like this old Ascension Material.

The Alpha Aether looks completely different, you can see the greek Alfa character on it.

1 Like

Hi everyone,
There’ s a bug in AlchLab lvl 10, the old long forgotten dragon scale appeared in v.56.

@PlayForFun , @Dudeious.Maximus , @Petri


I am wondering what will happen to those who might accidently get this ancient AM as a result.

At least now who still have this can use it.


hello, I remember the presentation of the first ether in beta and its design was like this if I’m not mistaken


They will certainly have to contact support to get it exchanged with an actually useful / usable ascension mat.


Yes, it was looked like this.
Staff I suspect just reused this image as the Aether’s image is not yet complete at that time.


That’s a dragon scale, I think. It was actually an item way back in the olden days that got removed. A few people actually had them in their inventory all these years.

Edit: I see scrolling back this has already been answered. :ok_hand:

1 Like

Hi, thank you for the report. The old (and unused) Dragon Scale item should not be showing up in Alchemy Lab anymore. My apologies for any confusion caused by this issue! I’ll mark this topic as solved now.

1 Like

Lol I wish I know this earlier… I will just keep one copy as an in-game souvenir lol