[SOLVED] Delilah's/Thoth-Amun's minions do not do damage

I just used Delilah in a “collect battle items” quest. I noticed her minions attacks weren’t doing much damage. So I checked opponent health before attack and after and there was no change. Screen show’s the minions attack and how much damage it should do, but opponents health didn’t change

10 Likes

I noticed that problem also…

Same here. Her minions not working since the update.

arghhh war starts tomorrow… I like my lvl 80 Delila but now she is useless

Same problem here since update

@Petri Please look. Same problem

Yes. Same problem. Only Android. Please fix it until tomorrow.

1 Like

The health reading skips to the end value immediately(you can test this by sending tiles towards a low health opponent and quickly checking the health, should show 0). That should explain why the reading does not chance.
Atleast my Deli works ok.

Edit: Ok looked at the screens more carefully, and it is a clear bug(makes me wonder how it happens as I didn’t have any problem). Have you made a bug report?

Nope, the problem is also on iOS, so it’s general

1 Like

I have an android and just used her and she works for me

You have the new update?

I thought I did. I just updated it. It deleted the game off my phone so I had to redownload it. Delilahs attack is now not working on mine as well

iOS here. And all minions on all three Delilah are not hitting.

@Petri please help

1 Like

I have to disagree here. It looks from the screenshots they are hitting. But they’re doing fake damage.
:stuck_out_tongue:

@Petri

Someone in the german chat are reporting that Thot-Amuns minions are broken as well.

Ah yes of course, the patch. That did it for me as well. Send a bug report, let’s hope they fix it fast.


Thoth also not working. Seems all minions have been replaced with Red Hoods non-damage ones?

1 Like

Just tried my Thoth too. He isn’t working

@MantisToboggan

Yeah this is what i had in mind too. Something is messed up with the fox from Red Hood

1 Like

Same in raids

20 chars

Cookie Settings