[Solved] Cannot log on the game

Am not able to log on the game.
Any advice?
Thank you.

You can contact support about it here:

Can you give more details?

What device? What version of OS? What version of E&P?

How far to you get?

Do you get any error message?

What have you already tried?

Hi Oxide. Appreciate your kind assistance.

When I try log on, the Small Giant screen comes on for about 25 seconds or so. Afterwhich; I am back to my normal Samsung screen.
I am on Samsung Tablet A7. I have two other EnP accounts on my other Samsung devices and I encounter no problems logging on with them.
EnP version 62.0.1 Build 2089

No error message at all with the exception of my Samsung device telling me my EnP game crashes too often.

Will try to take a screenshot and post it shortly.

Thanks for your kind assistance. Am most appreciative.

This is the screen. No error messages whatsoever!

Can you try clearing both data and cache for the app?

Something like settings>apps>empires>storage then clear data and clear cache.

Hopefully this will get you past the Small Giant page to the splash screen of Richsrd/Elena/Buddy which should have a progress bar as it re-downloads it’s resources. It will only take a couple of minutes, depending on your connection speed.

Decided to uninstall the game after I failed so many times.
Reinstall the game after that.
All is good.
Not too sure what went wrong with my device. But thankfully after I uninstall the game and reinstalling it, everything was back to normal.
Apologies for troubling you about it!
Thank you for the kind understanding on your end.

1 Like

After many failures trying to access the game, I decided to uninstall the EnP game and reinstalling it. I am now able to access the game as usual.

Apologies for troubling everyone on this issue. Never had a problem of this nature before, hence, I never thought about uninstalling the game and reinstalling it back.

Thanks for the kind understanding.

Appreciate the kind advice and assistance.

Warmest regards to all.

Take care.


Sometimes (usually after a crash) some resources can get corrupted, leading to hanging at that first screen. Usually forcing a refresh by clearing data and cache gets you a clean start. Obviously a reinstall gives an even cleaner one.

Thanks for the update, glad you’re back up and fighting. :crossed_swords:

1 Like

Issue resolved