Shop problem

Hi i buy items 300 gems. I get heros but i did not get items!

Please screenshot the item(s) you purchased. Frequently people do not read the statement over the item:

“Get at least 2 of the following”

Only two items are guaranteed.

1 Like

@Yosh, @iceman,

Just checking in, has this issue resolved?

1 Like

Nope nothing changed.

1 Like

This might resolve when you update to 1.9 (this could be one of the generic ‘bug fixes’ that get listed with each update)

Post back here once you’ve updated to version 1.9. If there’s no change I’ll boost the signal in the Moderator thread. No promises, but might at least be able to find out how big this bug is for you and get you a possible timeline.

(definitely post back! The reply flags me and it keeps it on my ‘to do list’!)

This is most likely related to your device settings (make sure no restrictions are enabled). There shouldn’t be any known issues with purchasing.

You can find more information and troubleshooting tips from our FAQs:

1 Like

hi, i have the same problem as my gem shop keeps loading…
i don’t have google payment account in my device… i just want to see what gems offers are there!!
i reset my phone several times… and still loading!

Hi, a player of my alliance can not make purchases in the game, the screen freezes and is forced out. how can you solve? I attach screenshots. thank you

I have the same issue, i have edited my google play account to be as free as possible, i’ve turned off my phone, i’ve updated the game, i can make no in-game purchases.
It worked briefly after i changed my country to canada and added paypal. But it stopped the next day, after i had made no additional changes

I have figured out a fix.
Go to your play store, change your authentication requirement for making purchases, that forces you to log in, restart the game, you’ll be inundated with ads, and your shop will work

The workaround no longer works for me. Any other ideas?

This statement is very surprising to me. What do you mean “inundated with ads?”

The only things that should ever pop up in game are things like a splash screen for the currently active summoning gates, or a splash screen for any special in-game offers that are currently running (like the Atlantis gem deal when Atlantis is active).

Are those the ads you’re talking about?

Well, the phone screen is not very large, so the extra few icons around the frame feel like inundating, and yes, advertising anything counts as ads. It’s been so long since it worked, though, i can’t remember specifics


Been a week. Used to be fixed by deleting cache. Nothing works now. F2p now whee

1 Like

Same here… A week no shop

1 Like

No response hm? Its not google pay.

1 Like

Having same issue following ipdate.

this is a pain, I can’t renew my VIP! I’ve tried everything but no luck, this will mess with my plans of pulling for Kingston.

Was anyone upgrading their stronghold at the same time to 22 when they did the second update?


Screw you stupid 20 character ■■■■■■■■

Cookie Settings