Scrolls of Alteration Issue

Since new mythic titan, I have used 5 scrolls of alteration and no new tiles showed up on the board in any of them. Then tried on a regular titan and no new tiles again. What gives? Anyone else experiencing this?

Are you clicking/choosing one of your heroes, for the tiles to change colors to match that hero?

1 Like

Yes. The scroll was consumed and no new tiles showed up on board

Are you using a miracle scroll by any chance?
Can you record a video of it?

2 Likes

No it was alteration. I just updated game though so maybe that will fix it. I’ll try it again later tonight

There’s no way to say this without coming across the wrong way, but when it didn’t work the first few times, why didn’t capture this issue via video (or at least screenshots)?

Well to be honest I’m not very tech savvy so recording is over my head…lol…I can barely get a screen shot to work…

However after updating I went back in and hit the titan and the scroll worked. So I guess I’ll call it a wash and just eat the 5 or so scrolls I lost. Im not trying to be competitive anymore so I don’t use scrolls much anyway so I got some reserves.

I just thought maybe it was a known widespread issue or something but apparently not. And I’m coming up on my 4th year I think of playing so belive me I know the game and I definitely wasn’t imagining it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings