Received mystic vision announcement saying fixed but still doesn’t work

I received a message saying the mystic vision has now been fixed but mine still says it is not fixed and don’t have a timer or an MV to click on.

3 Likes

You’re better than me. Since I collected the WE flask awarded by SG for the mystic vision incident, my game crushes every time I try to launch…

Same problem!
Over 2weeks no mystic vision

1 Like

Try rebooting device? That might help

I got the flask and a mystic vision today… I also uninstalled and re-installed a few days ago. Could that be a solution? (Also did the two updates linked in the forum for Android WebView and Chrome.)

1 Like

Same here, idk what’s wrong … I hope someone could enlighten us.

Same issue. Tried everything, still no use

Just tried mystic vision and it is not available. After I watched a video. I thought it was fixed as well and collected the energy flask and deleted the post.

Same here. Did everything. Restarted app. Cleared cache. Rebooted phone. Logged out and back in to google play. Still no mystic vision. Strangely it’s always the things that are good for the players that fail to work. Their crappy summon mechanics never fail. Maybe pay the same attention towards your players than you pay to their money SG?

Waited & clicked on ‘X’ which appears upper r/hand corner & no reward. Have suggested to drop MoPub ad.

The same and Idk why. Not fixed still

Mine seems to be working on my android today but not sure of my iOS tablet as I haven’t used it yet but yesterday it did not work on either one.

I also still don’t have MV after updating (IOS).

No MV, had two xays ago and again no

is it true that the mystical vision has been fixed? why are there still my alliance partner can’t use it yet?what happened?

1 Like

My mystic vision is clickable and I can click it but the game freezes completely after the add and sometimes while the rewards screen appears .
I’ve already applied the workaround suggested but it’s worse.

I still don’t have MV after they claimed it was fixed, I got 1 video & then it was gone again. I’ve rebooted, updated my game, etc & STILL no MV. Anyone know what to do from here? The update may have fixed some but not mine :pensive:. Open to suggestions. Thank you! :relaxed:

1 Like

Mistic Vision is not available again?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings