Problems since latest update

Since updating to version 25.1.0 Build 673 I get booted whenever I try to use a raid flag, a tournament flag or war flag. The game doesn’t take my flag, it just doesn’t register. I can use world energy flags and titan flags just fine but my titans show up like this:

Tried uninstalling and reinstalling. Tried powercycling my phone. Problem persists on both WiFi and LTE. Tried on both an iPhone 8+ running iOS 11.4 and an iPhone Pro Max.

Yes. The problems started after downloading the update…

The ! Link for the update sends me to the App Store with a “open” button.

I have close and re-open the App Store and do a search for e&p in order to download updates.

This doesn’t sound like your problem though if re-installed. I hope you get better answers from a submitted ticket

The (i) link isn’t there because like I said, I’m on the latest version.

@Ashera hope you can get solved ash, we need your monster war hits.

@zephyr1 @Petri @Rook don’t leave my sis hangin!!!


Booted out in quests and every titan battle freezes where tiles no longer move. Timer counts down yet tiles freeze. Hard to test heroes when you can’t complete a quest level, titan battle or even get to charging their mana up to activate their special.

I’m not sure what would cause that.

@Ashera have you contacted Support?


Wrote a ticket 5 hours ago, still waiting for a response.


I’m having a similar issue with the war flags. The only time I can use a flag is when I have a full team otherwise when I go to attack it sends me to an error screen and reboots back to the start page.

I’m not sure if support is open over the Thanksgiving holiday. That may (or may not) cause delays. :slight_smile:

1 Like

Hi @Jaybay76
If you are talking about testing heroes in beta, that discussion belongs in the beta lounge :slight_smile:

1 Like

The update rolled out today fixed my game, thanks. This can be closed.

Closed at OP’s request. :slight_smile:

Cookie Settings