Problems loading game after upgrade to V62 running in Bluestacks Great

Nox still doesn’t support Hyper-V. Bluestacks 5 takes half the RAM of BS4 and supports Hyper-V


Ver 62.0.1 build 2088 solved my problem with Bluestack. I was using Nox in between but Nox has some issues. Sometimes it just freezes up. Not so good in war and competions.

1 Like

Got the update too on my phone. Hopefully it fixes my issue with BlueStacks too and everyone else’s crashing and connection issues lately.

1 Like

So, even on a fresh Android 11 VM with the v62.0.1 update, it still crashes the whole VM on the SGG splash screen. My VM settings are 4 cores, 4GB of RAM, performance mode, DirectX rendering, DirectX GUI rendering, and software decoding for ASTC, with up to date BlueStacks and GPU drivers. I tried with ASTC disabled but still exactly the same crash.


Using newest drivers and newest bluestacks 5 also getting this crazy bad lag. fps constantly bounces around from 29-51 and will not go any higher for some reason. Mine barely crashes at all but the lag is unplayable.

Now the Mystic Vision ads won’t load. Tried with the latest build but it just says loading ads and gets stuck there for a long time. And when you click watch, all you see is a black screen. Which also closes after a while and you’re back to “Loading ads…”

I changed setting to OpenGL and it works now, even with Mystic Vision ads

1 Like

i still can’t play it’s been like 4 days now since i updated the game and it never worked since. i guess ill take my money elsewhere

1 Like

I’ve tried OpenGL, Vulcan, Pie, Nougat… nothing works. Same issue as here


Went back to BS and so far things are looking stable. I’m running Pie 64 with OpenGL/DirectX/Software ATSC with dedicated GPU.

@Elioty33 worth a try


How u get a lower version of bluestack ? i should try nox too :frowning:

I just entered bluestacks and the version number into google, e.g.:

I was able to get Empires and Puzzles working with Bluestacks version

I created a fresh instance using Pie 64 for the version, 2 cores for CPU, 2GB memory, portrait resolution, x86 & ARM for ABI, Low Memory for Performance, and left DPI at 240.

For the Graphics Settings, DirectX for renderer, Software for Interface (DirectX also worked here), Software for ASTC, and Prefer dedicated GPU enabled.

I still see the weird black box with green letters when launching E&P, but it only shows up for a second or two and disappears after the game loads. I haven’t had issues with Mystic Vision so far, but haven’t done a lot of testing yet.

I used because I had a few crashes with the latest version of the Bluestacks App Player.

You need to uninstall your current Bluestacks, then use the older installer to install the older version. BS doesn’t make older version available on their support site so if you don’t have the older installer downloaded, this can be tricky. Google, reddit can be of help.

Tried older version but ads not loading too, have white/black screen , now i’m used the last version of bluestacks n32 with compatibilty mod, direct X graphic , direct X interphase and ASCT disable.

Tried nox but was terribly laggy, crashing.

I have given up trying to find settings that allow the game to run and the ads to load. I run the game in Bluestacks but open ads on my tablet or phone

Not perfect but at least I can access everything

Did you sign up for and try the public test of v62.0.2 which is a candidate to fix other stability issues? It might overlap with BlueStacks issues.
See: [KNOWN ISSUE] The game freezes during a league battle

I also noticed that when I have show fps on that the game will limit itself to 30 fps for literally no reason. I have it on 60fps and it run really smooth but then for no reason with clicking something it limits to 30 and looks jittery as hell.

So, BlueStacks support told me it was “fixed” (it was before the recent update) and to try on Pie 64 but of course, it crashes all the same on Pie 64… Same thing after the recent update. Had to open a new ticket (because they already closed the previous one and the “create a follow-up” link on their ZenDesk does not work…) to tell them to get their stuff together and to fix their regression as the bug doesn’t exist on older versions and that the latest version still got the bug. So well, I’m not happy by this kind of support. Stay tuned for the next episode :stuck_out_tongue_winking_eye:

1 Like