Problems loading game after upgrade to V62 running in Bluestacks

Personally on v61.0.2, still crashing the whole Android VM when starting up the game even after updating my GPU drivers. I gave MEmu a try though and I played for about 2 or 3 hours last night, with Mystic Visions and mostly League attacks and CoE stages, a couple of titan hits and I didn’t encounter any issue :smiley: I will try again on BlueStacks once I get v62 though or when BlueStacks itself gets an update.

1 Like

Got the v62 game update this morning. Still the same under BlueStacks 5, it keeps crashing the whole Android VM when booting up the game both in Nougat 64-bit (Android 7) and Android 11. Oh well I guess I will play more with MEmu then until it’s fixed somehow. I made a bug/problem report on BlueStacks though, so hopefully they can reproduce the issue on their side and work on a fix :smiley:

I play on Memu, and the problem exists. The game freezes from time to time, but usually on the “disconnected due to no activity” screen, so it is not very problematic.

I had this screen on twice last night as I was doing other things (multitasking is why I love being able to play the game on PC) but the game just reconnected and kept working fine when I clicked ok. Will see how it goes over time.

StrontiumDuck

After trying a few more options I found that creating a new Bluestacks instance based on Android 11 and setting the graphics and interface renderer to DirectX seems to resolve the problem for now.

Thanks StrontiumDuck et al. :star_struck:

I was having the same Small Giant loading-screen stall as many since the Nov7 E&P app update in Bluestacks5 (BS5) on my Windows10 PC. :frowning_face:

Tried making BS5 setting adjustments in both Nougat64 & Nougat32 instances with no luck. Note: I have NOT enabled Hyper-V on my Dell Win10Pro PC, but I do have all Virtualization Support options enabled in the BIOS setup (Boot-F2). I usually have no problems playing E&P on BS5 Nougat64.

Well at least the latest E&P updates run fine on my tablet, so been playing on the small screen for the last couple days while searching for a PC/BS5 fix.

Anyway, as suggested, I created a new Android11 instance in BS5 and set Graphics to DirectX (I left Interface on Auto). Logged-in to Google Play Store then installed the E&P app. E&P is once again loading successfully & running fine ‘for now’ on my PC … WooHoo !! :smiley:

I don’t understand the step Android11 instance in BS5. How exactly do I enable Android 11 ?

Never mind, I found the multi-instance manager.

1 Like

Going with Android 11 & DirectX also worked for me. Not only this, but I was previously having an issue with watching in-game ads causing the game to crash, and now that appears to have been fixed as well.

Yeah, I never even knew Pie64 & Android11 existed in Bluestacks. Been using Nougat64 & 32 since I upgraded to version 5.

For anyone else looking: Using latest version of Bluestacks5 … open the Multi-Instance Manager, choose Instance (bottom-left), choose Fresh Instance, select Android11 from pull-down list.

Won 5of6 in BETA League today. :smirk:

1 Like

The screen keeps freezing, this happened while fighting in the League, while hitting the Titan and while I’m doing normal raids l

He tenido que cambiar a la version ultima de blue stack para que funcione

Solved this one :slight_smile:
The issue is OpenGL rendering.

  1. Create (with Bluestacks Multi-instance Manager) new virtual machine with Android 11.
  2. In Settings, choose DirectX rendering.
  3. Enjoy :slight_smile:

@Elioty33 , @PlayForFun , if there will be any more questions about Bluestacks.

P.S. Android 11 is a crucial condition.
Works on Android 9 (Pie) with DirectX rendering, but veeeery slow and with crashes.

7 Likes

Thank you for this. Now with Andoid 11 runs even smoother for me no input lag as well.

This morning I was forced to upgrade to latest and ever since the upgrade, my game doesn’t load. All I see is this

Running Nougat 64 bit on Bluestacks if that helps.

I searched but couldn’t find a similar topic but if I missed an existing bug, please merge this topic.

Lots of discussion,help and tips may be found here…

1 Like

Had to upgrade my BS to get Android 11 but I can confirm it works for me. Also Pie 64 works.

Here are my settings

Both need DirectX as the renderer or else you run into weird issues like this:

This update did mess things up big time.

1 Like

Already tried it with those settings, doesn’t work for me. Still crashes the whole Android VM on the black SGG splash screen at the application startup.

Running latest Bluestacks AND Android 11?

image

I have Hyper-V enabled. I was on 5.0.x and it started crashing there. Had to upgrade to get to Android 11 and then played with different renderers and only DirectX seemed to work.

YES. Also updated my GPU drivers just in case, cannot hurt. I send a problem report to BlueStacks devs anyway, they are looking into it.

3 Likes

We need compensation for the farming revenue losses that are staggering. Also, devs should note that: DO NOT MAKE ANY MAINTENANCE CHANGES BEFORE ATLANTIS!

thx who said about Nox. everything works fine there! :wink: