Problems loading game after upgrade to V62 running in Bluestacks

Just upgraded the game to v62 and now it will not load in my Bluestack Instance. Using the default 32bit instance the game hangs on the Small Giant loading screen and in other Bluestacks instances such as Pie64 and Android 11 the loading screen is corrupt as is the screen when you first click on an offer. The game aslo just crashes but the the bluestack instance home screen.

Problems persist after updating to latest version of Bluestacks

Wondering if anyone else is using Bluestacks and having similar problems


Use Nox Player or Memu
They are faster and better than bluestacks
Use android 9

@StrontiumDuck Using Bluestack here, same issue.

1 Like

Nox Player is buggy as hell, doesn’t meet the Windows Security Standards and comes with PUP.


Actually the problem is present on v61.0.2 already. It ran just fine on v61.0.0 but since I received the v61.0.2 update (haven’t received v62.0.0 yet personally), the app stays stuck on the Small Giant loading screen too.

Running with 64-bit Nougat Android under BlueStacks 5 with Hyper-V.


I have put this issue to mod chat


Thanks @PlayForFun

I’m running two instances of BlueStacks, both latest version ( P64), with Android Pie 64 / Hyper-V

I need this stuff for my professional activities (I’m a web dev).

The issue appeared after the latest update of the game.


1 Like

Well, I updated my BlueStacks 5 and it’s even worse. I tried on both Nougat 64 (Android 7) and Android 11 VM (the Android 11 VM being brand new, just freshly installed) and both just completely crash when I start the Empires app, not just the app freezing like before (only the app froze before, the Android system was still response, was still able to minimize the app and do other things) or having a corrupted screen like you. Just totally crashes the VM…

EDIT: I tried many different combination of settings. Even recreated the Android 11 VM multiple times to play with the ABI settings (this one cannot be changed on the fly, need to create a new VM to change it) to have ARM32 only or ARM64 only but still no luck, keep crashing when opening the app. I got the following line in Bluestacks logs:

8916 6976 WERH I: UnhandledException. Exception Code : 0x3221225501 ExceptionAddress: 0x00007FFA2E514214

Again on v61.0.2, if the given address can help the developers pinpoint the root cause.


What is a stacbk of blue

I use nox player android 9 and i’ve never faced any lags
Some rare crashes maybe,i dont care about nox disabling the firewall though.
i have a pretty strong pc gamer
Try Memu otherwise
Bluestacks eats much ram and tends to slow the pc

1 Like

I installed version 62 on nox and it works just fine

1 Like

Everything works smoothly on Nox Player android 9, but there were some problems with OpenGL, so I switched to DirectX.

Ok, so I gave Nox a try again… It seems to work fine and the game launches.

Indeed, it consumes less memory…

at least I can play again :slight_smile:


I hope it will be fixed soon.
I tried Nox and it crashed after 5 mn, BlueStack is much better.

In nox settings go to general and choose mobile
If you choose tablet it can make the app crashes sometimes


Petri’s had put this link in mod chat as an answer:

And he mentioned these emulators are not officially support.

I guess it means no fix is expected.


After trying a few more options I found that creating a new Bluestacks instance based on Android 11 and setting the graphics and interface renderer to DirectX seems to resolve the problem for now.


Hmm pretty sure I tested this combination on my side with no luck, kept crashing the VM. But I need to try again after updating my GPU drivers.

1 Like


Thank you it’s working ! :slight_smile:

Android 11 64 bits has to be downloaded here

If you are playing on many devices and the game is asking to update to the last version (build 2085) and this build is not availble in google play, then download and install the apk from apkpure for instance.

I can confirm that going with Android 11 & DirectX graphics does the trick.

Edit: the game keeps crashing even on Android 11. I guess we may have to wait for another version and hope it is going to work.