Problems after new update


#21

Con la nueva actialiciacion el la alianza perdimos ataques en la guerra en el titan y las cartas de heroes salen borrosas


#22

after the last update the evocation of “Delilah” does not cause damage to the opponent


#23

After Last Update (1.12.5 Built 733 )Minions Delilah does not deal damage and the icon of the game disappeared from android. Smartphone Oneplus 3T. Reboot does not help. I launch the game through the Play market. What should I do?


#24

Iphone 5S iOS 11.0.3
Screen pop-up: UPDATE AVAILABLE / Good News! There’s a new version available in the store. / [UPDATE] button
Back Screen: RECONNECTING… Account: xxx Version: 1.12.3 Build: 381
I push the UPDATE button and go to App Store Empires & Puzzles App page version 1.12.5
I push the “open” button and go back to the beginning of this note. Screen popup UPDATE AVAILABLE
I don’t know what I am doing wrong, I have cleared cookies and rebooted phone as others have done. I do not know how to submit a ticket to customer support. Can anyone help?


#25

#26

Loose 2 tickets on aliance wars, my connection was fine but it said have error server connection. And i got 2, zero points and 2 teams heroes used. Please fix this!


#27

I am noticing same issue Delilah’s Minions are not doing damage now. Although it shows damage the health bar was not lowering and sure enough clicked on defending enemy after hit by minion and no damage had actually been done.


#28

I also get the blurry hero cards but then they come right. Only started happening since the update …


#29

Fix Delilah, please, have the same problem with no damage of her minions.


#30

Since the update the game has crashed multiple times losing 1 titan hit, 1 war march, and 2 raids. Screen just goes black and closes out no problems with Wi-Fi connection and other Apps are working fine.


#31

Same problem, heroes don’t load full image, the game suddenly freeze, also lost flags of titan, world energy and war.


#32

Just tried a raid with the new version. Did get the server communication error and caused a loss even though I defeated the opponent.

Very frustrating.

@Petri


#33

Problem updating on iphone. When opening the game I get “update available” notice with “update” button for just a moment then a slightly bigger otherwise identical notice. I touch the update button and it takes me to empires & puzzles in app store. I touch the “open” button and it takes me back to the game’s “update available” screen.
How do I get back into the game?


#34

You cant wait for the update in the store. Had this issue as well with the previous update. It will be there soon.


#35

Have you tried going to App Store/GameStore and swiping down to refresh the apps?

I have my phone set to manually install apps and I often have to swipe down to get those pesky updates to show.

Hope this helps!


#36

Hello, my ally fight against Titan, I can’t. Shows me Titan is death.


#37

Jest compleated legendary level 9 … shows I did not !!!