Please Read this before posting a bug

As there many bugs always recuring in the bugs category I decided to do this topic to help with common bugs, reduce merging , repeating same answers and help find answers easily for common bugs

We will talk about type of commun bugs found here in the forum and the solutions, but please before posting any kind of bug do/read the following:

  • Always make sure that you signed in into Google Play/ Game Center to avoid loss of game progress
  • Make sure the game is up to date
  • Make sure there is enough space on your device for for all apps run smoothly
  • You have your account# saved securely with you AT ALL TIMES (this will be changed when re-installing, changing phones, playing on multiple devices)
  • Sharing a video or picture to show the bug (game freeze screenshots are useless as it cant be verified)
  • Have the exact date/time this happened as support will likely ask you
  • Check the following topic
    [Wiki] *NOT* a bug FAQ
  • If you didn’t find the solution here or you tried the solutions and didn’t work try the search function for similar bugs before creating a new topic

1- Version Bugs: it is caused after releasing new update or patch to the game and its general to all playere such as the revive issue, or the auto correct and captilazation
(Mods please help to keep the links for all known bugs related to versions here, till they are solved)


Bug is scheduled to be fixed on V26 :arrow_up:


Still no schedule when it will be fixed as they are working with another company to find a solution :arrow_up:

And usually it gets fixed with a patch (if its a major bug) or with the next version update

2- Bugs related to the account such as purchase bugs, lost account, lost items/heroes/gems/etc. In this case you should contact support directly without posting in the forum as you will only get a reply of contacting support, if you suspect that you lost an item or hero please check your “Recent Activity” to make sure that you didnt use them any where as many cases were the player used that specific item or gems

3- Sudden visual bugs or glitch; by this i mean sometimes the player will see a black area on the map or a hero is pixilized or any other visual bug that wasnt there before and there was no update released this is usually fixed by restaring the game or/and your device and if it didnt work try clearing the cache of the game
Android (Settings > Apps > Empires > Memory > clear cache)
iOS I still didnt find a way to clear casche for an app other than re-installing, before re-installing please check the following:

  • You have signed in game center
  • You have your account # saved (just incase anything happened)
  • You have stable connection when downloading the game

4- Game freeze or got kicked out of the game, this usually happens if you have unstable connection, connection dropped and got back, your device memory is full or almost full (this will cause the device to get laggy), your device is old or out dated: in that case no one can help you and you will NOT get your energy back regardless on what activity you were doing
PS: in very rare cases this happens when there is a server issue and usually SGG will give a flask to all affected players

Latest Version release notes and bugs they fixed:

16 Likes

This needs to be stickied, stat!

8 Likes

This is definitely great. Also, problem is most users don’t use the search function and often create duplicate posts for the same bug without checking if someone has already reported it or not. :slight_smile:

4 Likes

New point added to the original post

2 Likes

Good idea :slight_smile: I’d also suggest including this link:


Edit; I suppose I can help too since you asked us to keep it updated for you :slight_smile: I’ll check in when I am not running errands to help out

3 Likes

I removed the auto close timer, and pinned it to the top of #bugs-issues :slightly_smiling_face:

7 Likes

Known bugs has been updated with the release of V25

2 Likes

I completed Battle Items II quest but didn’t receive the loot. Specifically I noticed I didn’t receive the lumber or loot because I was at zero

1 Like

Did you check in your recent activity log? :slight_smile:

Go to Options > Support >Recent Activity

Can’t purchase gems :frowning:

hope this will be fix before event ends :frowning:

This is likely a connection issue.

Cookie Settings