Paid for monthly pass and it never appeared - Resolved

Good morning,

I just purchased the 30 day VIP pass this morning and after purchasing it, nothing has appeared, the dragon that should roost on my stronghold isn’t there. I can see the charge on my account and when I try and re-purchase it in game, I get an error saying I already own it.

Would clearly like to get my VIP pass that I paid for or a refund. Thanks!
Phim

1 Like

Try logging completely out of the game (Game Center or Google Play), then log back in. It should appear after that. If it doesn’t, submit a support ticket

You’re the best NPNKY that worked. I think the core move was to sign out and in and then restart the app! Time to get my gems and say hi to my dragon companion!

Thanks again.

1 Like

You should press on solved button to let others know the solvation of this issue if any gets it later.

He did. Look at the title

He wasn’t when I replay :smile:
Thats why I replaied :wink:

1 Like

Hi NPNKY,
My transaction ID - GPA .xxx was stucked. I paid the bill but not received VIP. please solve for me

Thank you!

Hi @Anhnh0411

@NPNKY is just a player like the rest of us. You’ll need to contact support in game or your app store to assist.

Also, I’ve removed your screenshot in case it contains account numbers.

Good luck :slightly_smiling_face:

Thank you so much for protect my personal infomation

Cookie Settings