Not able to update the version 50

It’s very weird… I tried to open the game and it has blocked me and asked me to update, I go to update it but… There is no update available at the Google Playstore…
I thought it might be my cellphone or just some error and tried to clean the cache and the data(like it’s said in the SG help) nothing happened. I went further and have uninstalled the game twice or thrice and reinstalled again but always as version 49. All my mates have achieved to update and it’s very weird that it asks me to update but with no new version to be updated…
What shall I do?

@Petri @PlayForFun @Dudeious.Maximus urgent matter, this could be troublesome for the ongoing war if this is a widespread issue. The release notes for v50 don’t even state that the rollout is complete yet (EDIT: and it clearly isn’t since this poor Vinsten73 isn’t given the update) so it’s very strange that the update would already be enforced on the server side!

@Vinsten73 you are totally blocked from the game …
Also can you put in English

What that says please :+1:

I used Yandex Image to Text translate and it says:

You recently accessed a
newer version of the game than the
installed on this device.
Download the latest version from the store or
keep playing on the other

Update | More information


1 Like

It’s written that I have entered with an old version of the game. It asks me to update
But when I push update the app opens in the Playstore and instead of update(atualizar) it says play(jogar) so when I push play there it asks me again to update

1 Like

Are you ios or andriod

And you cannot access the game at all .

Android, no I can’t at all

I think you have logged into your account with a device where Version 50 is already installed.

You will not able to log in to your account with the device which is still on version 49.
This udate will not be available on that device with Version 49 during the current war.

Use your other device for finishing your war flags.

Unfortunatelly this is the risk of logging in with multiple devices.


Aaaah thank you for the translation, I thought it was the “forced update” message but it actually isn’t. So it’s not going to be a widespread issue, sorry mods.

So yes, just a multiple device issue, with some of them catching the update sooner than the others and thus upgrading/locking the account on the newer version.

I have used Google Lens application for translation :slight_smile:

In fact I was in the Amazon jungle and had no internet so I asked a mate to fulfill the duties (war, titans and path) and we I came back

1 Like

Your mate certainly have version 50 on his device already then. You can only be patient for your phone to be taken in the update rollout. Nothing SGG can do, it’s Google’s job. Maybe contact Google’s support instead next time.

1 Like

Your mate will need to do war for now. Till your device can upgrade to V50

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.