Not able to buy special yesterday

Did anyone else have issues purchasing the special yesterday? I was never able to do it after trying a few times. Seemed like it he disappeared in the morning and then was back but every time I tried to purchase it received the attached error.


Sucks I could have used it. Haven’t tried with today’s as I don’t want that one.

1 Like

Im having the same issue. Ive been trying to purchase todays special but it comes up with the same message. Hope i get it before it expires. I have contacted iTunes store just waiting on a reply, any help fixing the problem will be much appreciated. TIA

1 Like

I’m having the same exact issue for two days now. I’ve changed payment method on my phone three times already but the problem remains!

I’m having the same issue today 7/519… I didn’t try buying yesterdays deal though so I don’t know about that but I’ve also tried buying gems just to see if it would work and it didn’t… not sure what’s going on… It would be nice to get the chance to purchase before expiration… Just thought I’d share… thanks.

here’s picture of failed purchase

Someone I know recently got this error when they tried to buy something with too little money on a Google Play gift card. Many jurisdictions in the United States are now forcing Google and Apple to collect taxes on online purchases. When my friend added enough extra money to cover the tax, the purchase went through.

No idea why Google is giving such an unhelpful error message though.

Ok so I brought the issue to my alliance and someone suggested that I close everything out and turn my phone off and back on and it actually worked so try and do if you haven’t already!

today’s deal I bought after doing it!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings