No update & game not logging in

Several members of my alliance including myself, are unable to load the game. I think the majority, if not all of us haven’t been granted an update option on google play yet.

Anyone having the same problem?

War is starting, not having updated every single device is unfair, preposterous and ridiculous…

I haven’t done the update yet (though the update can already be downloaded on my Google Play), but I am logged in.

We haven’t still fully rolled out the update yet, so please wait a bit - it should be available soon! :slight_smile:

If you are unable to login, did you update your game in one of your devices?

1 Like

Thanks for the reply, just did the update, most of us too, but I’m still experiencing the loading problems!

Edit: it downloaded something during loading after a few tries and now it’s working as should, thanks again

I have the same issue since this morning. Last night it still worked.

But now I get an error about connectivity issues.
But all other apps and internet is working
Deleted and reinstalled the app. Changed my home LTE to my phone internet but still no luck with getting into the game.
(iPad)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings