No Mystic Vision since 27.0.0 update

Edit: After today’s update to 27.0.1, I am getting Mystic Vision again.

iOS 13.3.1 / iPhone 8.

Mystic Vision had been working for me. Occasionally it would say “No ad available”, but I would just quit and relaunch E&P and then one would appear promptly.

Since the update to 27.0.0, it is permanently in “No ad available” status.

I checked storage and freed up 10GB. (wtf Tile app.)

I have tried turning off wifi and relaunching the game with “5Ge” (which is 4G). When I say “relaunch” I mean after a force-close.

I have tried a relaunch of the game while connected to wifi both at work and at home. Before the update I could get Mystic Vision on wifi at both locations.

I tried rebooting the phone and then untoggle/retoggle wifi. (Recommended here.)

I tried Settings -> Privacy -> Limit Ad Tracking -> Toggle on, exit Settings and then go back in and Toggle off. It is off.

It sounds like you’ve done most of the troubleshooting. Have you contacted SG with a trouble ticket to request their help?

https://support.smallgiantgames.com/hc/en-us/requests/new

Yes, I have. /20characters

1 Like

Same problem :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings