"No ad available" AFTER seeing the AD, but WITHOUT receiving the reward

Quite frequently, I have the message “No ad available” JUST AFTER seeing the ad but WITHOUT receiving the reward


I then have to close the game, watch the AD again (the first or the second one, whatever) and finally get my reward.

It happens randomly on the first or second ad

  • 2 different accounts, on two different devices
  • Android Pie 64 bits, up-to-date
  • EP 60.0.1

My guess would be that it has to do with the ads service provider (invalid add due to expiry/timeout or ads service connection lost from game side).

It happens on my Android devices as well with latest software for OS 13.

It is definitely annoying especially that we have to watch the ad again.

1 Like

I can understand that ; anything to do ?

Definitely :rofl:

I don’t think we can do anything from our side other than closing the app and reopening it before watching the ads rather than watching the ad, failing, then closing and reopening and watching again.

Maybe because the ad that we watched was loaded sometime back that it is considered stale or maybe the game lost connection with the ads service that it waa unable to verify that the ad was successfully watched and to provide us with the reward.

Now we have 2 gusses, ads service provider or game issue (I will update my 1st post :smiley: )

1 Like

We all know getting the “No ad available” message is annoying - it’s been there for so long now - but after watching the ad ? (Yes, it’s happened to me too :cry: )

Sometimes I get the message “You have exhausted all available ads. Check back later.” (May not be exact wording but if you’ve seen it you know what I mean.)

So it would appear there is more than one cause here.

Not expecting anything to change. Only suggestion is to close the game when you finish your session rather than just switching away - May help. :crossed_fingers:

1 Like

I wonder if its just happening for Android users? Can anyone using an iOS device confirm this behavior as well?

I’m on iOs and I can’t even get a video to load

1 Like

This how mine has been as well since yesterday.

Two different iOS devices. Both stuck on no ad available all day

Same issue here. Screen has just been stuck at “Loading Ads” all day on an iOS device. Still occurs after a complete re installation of the app.

No ad available. IOS device. Still stuck after multiple deletions and reloading of app.

Stuck in loading adds here too ios updated restarted still stuck

thanks to all who contributes to make this thread visible !

hopefully Zynga will react with some update anytime soon :slight_smile:

Same issue all day today. “Loading adds” message all day long. I even uninstalled & reinstalled the app and nothing has worked.

Ive been having the same issue. Today will be 3 days in which i havent been able to do the free daily summons nor any Mystic Vision. Please fix this ASAP.

Issues seem to have been resolved today. My guess is that there was a bad video trying to load and failing miserably… Now, the videos seem to load MUCH faster.

No more issues for me today too.

Unfortunately, it still wont work for me. Mystic Vision stays at “Loading ads” the entire time and the free daily summons says “No ads available. Check back later.”
I unstalled and reinstalled.
So frustrating.

Funily when i had this issue, i use another device having old version 60.0.0 which is able to see ads normally

But the issue is also solved to me since yesterday

Finally! I deleted and reinstalled one more time, and it finally works. Glad to be able to utilize MV once again.