New update?

I saw there was a message from E&P, so opened it to find advised there was update 11.1.7 (or so I remember). Cleared the email, and went to the app store where I updated my game.

My page upon opening says it is version 11.1.6.

Have I got a problem with game or memory?

2 Likes

You may want to check your updates because mine was updated and shows the latest build.

Same here Bud, outdated game and memory, lol.

I guess the update takes longer to make it to some of us.

1 Like

Lol, I just noticed that on mine. Who knows…

1 Like

Hmm…this is what I have when I look:

(No, I’m not gonna download everything else lol)

I’ll just check every so often. It’ll be along soon enough. Maybe not the memory so much! :grin:

1 Like

Mine says from 2 days ago (iOS).

Have you tried swiping down to refresh the app downloads?

1 Like

11.1.6 just came out a couple of days ago and 11.1.7 came out today I think

I have android. It is challenged

1 Like

Same. I even rebooted phone thinking it was having a derp moment and still not there.

Yo, Rook.

Is this an issue/bug?

Has anyone gotten the update yet on an Android device?

In the Netherlands Playstore just gives 1.11.6. So no update for me.

Same here, except for I didn’t delete the message from Inbox. Android Play Store doesn’t know yet about an update to 1.11.7.

2 Likes

No, I know android and ios are usually issued separately so as not to overwhelm the system. Check again tomorrow. :wink:

1 Like

Tomorrow!?!

I’m old. Tomorrow is a vague promose…like TC20

1 Like

I have two TC20’s. Some of the promises are kept. :wink:

1 Like

5% promise is close to an old blues lyric

1 Like

I’ve gotten two 5* from tc20 and only been running them 2 months now… All hope is not lost simply because the percentage is low.

And back on topic Google play is still at 1.11.6 for me.

3 Likes

My game won’t update either…:frowning:

Cookie Settings