New Battle Item Notification Missing

When I collect a new battle item from a forge or the lodge, i get the notification that i have new items in inventory, but when I open up the inventory screen itself, there’s no notification icon on the battle items tab.

I think you only get a notification if it is a 3* or higher item.
I could be wrong on that though!

1 Like

Yeah, but I’m not getting the in-Inventory notification for 3*, 4*, or 5* items either. Just the one on the main menu. Lemme get screen shots, hang on…


I see what you mean.

I just tried it with a Super Mana potion and it was showing OK for me (iOS)
Weird
Sorry can’t be of more help

No worries. I honestly don’t even really care! lol

Just thought it was worth reporting for OCD purposes. =-]

Update - I just tried it with a harpoon, and got the same visual bug as you!

So
a) we are not going mad
b) neither of us really care
c) the OCD tendencies are satisfied for both of us

2 Likes

Looks like the German version works fine:

Cookie Settings