Mystic Vision stuck in "Loading Ads" state

Starting from yesterday I can only whatch Mystic Vision very rarely (maybe I could watch 2-3 yesterday, and none today) as it stucks at “Loading ads” state.


Yesterday I was on version 49, and I have updated to version 50 today.
So this is version independent.

I have already contacted support with not much luck.

I have tried everything what Support suggested:

  • Free up space on device
  • Free up memory
  • Restart the game
  • Clearing game cache

None of them resolved the problem.


One important bit of information you forgot to mention: iOS or Android?

No problem on my side on Android though. Might be a platform and/or region issue only.

I am on Android.
I am not using VPN.
I have tried it on Wifi and 4G nettwork too.

1 Like

We’re sorry to hear this. Unfortunately, Mystic Vision availability is tied to a plethora of factors (such as your physical location) and there isn’t really one magic-bullet solution — but based on similiar cases we’ve seen, we believe your problem will most likely “naturally” fix itself within a few days, if not less. Please ping support again if this doesn’t clear up within a few days.

1 Like

Ok, thx for your answer @DD26 !

1 Like

Have you tried turning WiFi off then on, and then restarting the game, this usually works for me

I have tried everything… with no luck.

I could still not be able view any MV since…

Yesterday at least 1-2 MV were allowed. Today so far 0…

1 Like

I also have this issue too. That is sad.

Mystic Vision is my main source of 4* ascend material and costume key.


I have the same issue and I think it is the 3rd day with that issue. All the time issues with free video…no video or video which have to see 3-4 times to get the rewards

1 Like

I can not even watch videos…

When I am lucky then I can see 1 or 2 a day.

It is very annoying, and it us still not resolved…


Me too… All day just 3-4, maybe for 3 days after use v50

1 Like

As you can see, this is not an isolated problem. For the past few days, I’ve been hitting the ad icon faster than the rare titans. I’m sure there is an explanation for this. No one is asking for compensation, just explain.

Im on Android and have not had the problem of stuck on loading… My issue is right after that… A circle appears like it is loading… Then it locks up for couple of seconds…then completely kicks me out of the game… Just did it again few minutes ago… Hence me joining here cause response from SG is lame at best… This time it at least said E&P not responding… And yes did update When released… Sry so long…

Non può essere un problema fisico di dove ti trovi. Il coinquilino nell’appartamento di sotto gli funziona benissimo. a chi non funziona il gioco ha un cellulare Wiko?

Hello DD26

Just an update on ths bug.

It was not fixed itself until today.
I could watch maybe only 1 or maximum 2 advertisments until today.
I have contacted support as you suggested, but afterwards I had an idea:
In Options / About the “Peronalized ads” checkbox was checked for me.
I have tried what happens if I uncheck it, and the ‘play’ button bouble immediatelly shown instead of “Loading ads” in the MV Tower, and I could watch a video, and receive the rewards.

Since this change I could watch MV in every 2 hours.

So it seems I have ran out of “Personalized ads” only.
This was not suggested by Support.
So maybe they can add it to the possible fix for the issue.


This worked until today…

It is now not working with the non personalized ads either :frowning:

Check for update on google play also, search also for dns settings and see that you don’t have it set to some adblock server or: go to settings->google->ads->reset advertising id

1 Like

I still have this problem. I’m on iOS and it’s very frustrating because I’m f2p and I’m obtaining gems so slowly now, not to mention ascenion materials and the rest. It seemed solved a few days back because I regularly had ads, but then the last 2-3 days I had them three or four times per day. Today, nothing, not even once. I have the latest update of the game. Please, fix it because it’s really driving me insane.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.