Mystic vision sound

Hello,
The problem started about 2 months ago, adjucent to one of the major releases.
When playing the ads in Mystic Vision, although the sound icon shows “sound off”, the sound of the ad is turned on. In order to turn it off, I need to tap the icon twice.
The fact that the sound is on has a major negative impact, as lots of players use the game in a silent mode, for the sake of not disturbing the environment. It became VERY ANNOYING now.
Using Samsung Galaxy A5 with android 8.0.
Have a video, but cant upload here.

Thanks,
Michael

Yes it is annoying. I sometimes have insomnia and play a bit and don’t want to wake up the family.

I too have had this happen. I now just routinely either a) have headphones in or b) just have the sound off on my phone itself.

Cookie Settings