Mystic Vision not providing loot

When I click on the mystic vision Icon the ad plays through I close it … and nothing. At first it seemed like it would provide loot about every third one. But apparently not. I’m currently at 5. When I say nothing I mean the little loot box doesn’t even display. Anyone else having this problem?

I had this problem this morning. I exited out of the game and reloaded it, and then it worked fine (after watching a second ad).

I’m currently having the same issue…the video will play and once completed it doesn’t issue loot. I’ve restarted the game as well the phone to resolve and same results.

Same here. After 8 videos and 10 hours still no loot!

I am also having this problem. I managed to get it to work again by force quitting the app, and used it once, and now it’s stopped working again.

@zephyr1 as this is not related to the master thread were mystic vision is not available, maybe you can create another master for Mystic vision not giving loots ? Seen several threads so far:

->>>last one should be master as @Garanwyn already merged this into it:

yeah the issues with MV are getting more and more frequent, sometimes I click the ad and it displays the screen with install button, like it already ended and doesn’t give a reward. Force closing the game doesn’t help, have to reboot phone. Right now I had to reboot to watch ad on one account, I signed off and signed in to alt account and boom, have to reboot again to watch it.

P.S. And maybe it’s unrelated but while this happens also the chat is stuck displaying only system messages and old messages form like yesterday, and it takes about a minute to show the latest ones.

1 Like

I am having the same issue with Mystic Vision opening to no video.

Been having the same issue for two days now. Rebooted game and rebooted phone. Still nothing

been having the same issues with Mystic Vision.

I’ve been having this issue for a couple of days. Click the Mystic Vision icon, watch a video, then no loot and the unclickable MV icon appears.

Not working here either

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings